BMW E46 Fanatics Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
164 Posts
Discussion Starter #1
When I purchased my car, the owner told me that he took the rear passenger upper window trim off because it was loose. He gave me the piece and said it was a easy fix. :hmm:

I did a little research and thought these were the clips that were missing.




when I received the clips, I realized that they are the same clips that are still intact on the car.

I actually needed the clips that were on the trim itself, which seemed to be glued onto the inside of the trim...





When I looked up realoem, it doesnt seem like they have a part number for it on there...

http://www.realoem.com/bmw/showparts.do?model=EV53&mospid=47725&btnr=51_3267&hg=51&fg=20


Anyone ever dealt with this problem ? Is there anyway to put the trim back on?


Sorry ECS, i had to borrow your pictures, you guys were the only one with detailed pics of the trim and pieces.
 

·
Registered
Joined
·
522 Posts
Sounds like it would be something that comes with a new piece if there's no part #
 

·
Registered
Joined
·
164 Posts
Discussion Starter #4
Those clips are not available separately. You need to order a new trim piece...
:hmm: that sucks that they dont let people by that part alone, i guess people wont know where to glue/attach it on the trim?


I tried using my hands to take the old clips off the car, i guess they dried up over time and they broke off with barely any pressure.

at least those new clips came in handy. :thumbup:
 

·
Registered
Joined
·
3,142 Posts
Yeah, I had the same problem with my trim piece off of my ZHP. I ended up buying a new trim piece and clips (pictured in the first post) so that I can change everything out. I guess the plastic clips over time get brittle and break. :rofl:
 

·
Registered
Joined
·
81 Posts
How many of those clips are still glued to the trim piece, or how many of the clips do u still have??? My trim piece is attached with only 2/3 and still holds just fine.
 

·
Registered
Joined
·
704 Posts
Hi. Did anyone try using the double-sided 3m tape to fix this? How are the results?

My sedan has this issue too. The clips are broken off and fallen out. No more clips on either the trim or the body. :-( The whole trim piece is some $150, which seems like a whole lot money for something so small (especially on my aging car).
 

·
Registered
2018 Audi S4
Joined
·
6,278 Posts
Hi. Did anyone try using the double-sided 3m tape to fix this? How are the results?

My sedan has this issue too. The clips are broken off and fallen out. No more clips on either the trim or the body. :-( The whole trim piece is some $150, which seems like a whole lot money for something so small (especially on my aging car).
I have and the stuff I used (3M) wasnt thick enough. Right now I'm using some 3M emblem glue I've had for 30+ years.

Sent from my SM-G950U using E46Fanatics mobile app
 
1 - 15 of 15 Posts
Top