E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Ride of the Month Challenge!
1 - 10 of 10 Posts

·
Bavarian Motor Slave
Joined
·
1,413 Posts
Discussion Starter · #1 ·
When I turn the car on, and then turn the lights on I get light that comes on and says my front right blinker is out.

I then hit my inicator "lever" (what ever the **** you call it) and the light blinks all quick like its out....


....then stops after like 6 clicks and blinks normal and the light is fine. WTF?



PS: I have Bimmian Platinumvisions
 

·
Registered
Joined
·
273 Posts
It means the bulb is about to die, so you need to change it
 

·
Bavarian Motor Slave
Joined
·
1,413 Posts
Discussion Starter · #3 ·
It better not, Ive had these ****ing bulbs for like 4 months and they cost like $80 for all 6.

I will be rip **** if it goes out that soon.
 

·
Registered
Joined
·
874 Posts
V330xi said:
It means the bulb is about to die, so you need to change it
That could be...but may not be.

A couple of things I ran across.
First, my car didn't have clears stock, so I bought amber bulbs---the bulbs weren't a good fit so the connection was intermittent causing that problem

Second, The actual socket had corroded to the point where the connection was bad. BMW replaced the bulb socket and the bulb itself under warranty!

Take out your lenses and look at the socket. There should be no corrosion on it, if there is, try cleaning it off and putting a fresh bulb in there.

That should cure it!

Good luck!
 

·
OG Moderator Extraordinaire
Joined
·
5,358 Posts
TheDream21479 said:


That could be...but may not be.

A couple of things I ran across.
First, my car didn't have clears stock, so I bought amber bulbs---the bulbs weren't a good fit so the connection was intermittent causing that problem

Second, The actual socket had corroded to the point where the connection was bad. BMW replaced the bulb socket and the bulb itself under warranty!

Take out your lenses and look at the socket. There should be no corrosion on it, if there is, try cleaning it off and putting a fresh bulb in there.

That should cure it!

Good luck!

yes I had similar results and problems...

I wound up changing the socket piece and haven't had a problem since :)
 

·
Bimmerless
Joined
·
1,551 Posts
Your corner bulbs are running hotter than stock. I have the same repeated problem. More likely, the filament (bottom tip) of your bulb is melting and not having a clean contact with the current coming in. Check it out.
 

·
Bavarian Motor Slave
Joined
·
1,413 Posts
Discussion Starter · #8 ·
so what the ****.


I bought bimmian bulbs and **** gets ****ed in like 4 monthes? Thats bull****, if something is wrong with the fillament of the connection its not my fault. there isn't really a wrong way to "install" a ****ing lightbulb.
 

·
Registered
Joined
·
1,962 Posts
I ran into similar problem. My front turn signal would go out intermittently. Later the dealer found that the socket was partially corroded.
 

·
Registered
Joined
·
287 Posts
drewcon said:
so what the ****.


I bought bimmian bulbs and **** gets ****ed in like 4 monthes? Thats bull****, if something is wrong with the fillament of the connection its not my fault. there isn't really a wrong way to "install" a ****ing lightbulb.
its the socket..tey takin out the bulb and prying up on the socket prong with a flathead...check the bottom of the bulb too..is the metal looking like its melting...?
 
1 - 10 of 10 Posts
Top