E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!
181 - 200 of 220 Posts

·
Registered
2000 E46 323i, 3.0L and 2.0L Z3's
Joined
·
989 Posts
You have to use 7z to unzip, the password is MS4X as is specified on the MS4X website..
Thank you for your help. The files unpacked but Norton antivirus didn't like them and removed them. Not sure if there is a virus in the pack or not?

Anyway, I have moved on with my project and no longer need to use MS4x Flasher or DME files.

Once again, thank you for your help.
 

·
Registered
Joined
·
6 Posts
Hi Guys,
hope you well,
wondering if you could help me choosing the correct file?
I have a 99 e46 318i 4 cylinder. think its the M43 engine.
The issue is no crank and no start, seems like the previous owners changed the dme and bridged a few wires to bypass the ews. i tried using PA Soft but obviously cannot sync the DME and Ews.
I'd like to flash an ews delete file from your site but I want to make sure i use the correct file.

please let me know.

Thank you.
[email protected]
 

·
Registered
Joined
·
6 Posts
Make sure you have the license in the same folder you have the MS4X app, wherever it may be, and you have to install the .net 4.7.2 or else you will probably have activation issues.
You have it full on my post, post number 172 on this thread.
I finally figured out what was happening. I installed a clean copy of Win 7 on my laptop and did not run the updates or all of them. After a full night of updating it immediately took and I was in action.
 

·
Registered
2002 BMW E46 330i
Joined
·
208 Posts
I am a little late to the party with the same problem half the users of this software encounter. The activation process is not working. I put the license key in the same folder as the app. I verified I have the NET .472 installed already which i do. I Am running up to date windows 10. I tried restarting my computer, but did not work. I tried uninstalling and reinstalling, did not work. I tried moving folder locations and moving the disclaimer and DLL file to other folders, didnt work. Is there something I am missing? Why can I not get the software licensed?
 

·
Registered
'01 320Ci manual
Joined
·
951 Posts
I am a little late to the party with the same problem half the users of this software encounter. The activation process is not working. I put the license key in the same folder as the app. I verified I have the NET .472 installed already which i do. I Am running up to date windows 10. I tried restarting my computer, but did not work. I tried uninstalling and reinstalling, did not work. I tried moving folder locations and moving the disclaimer and DLL file to other folders, didnt work. Is there something I am missing? Why can I not get the software licensed?
You download the app, you run it. You disable windows defender live and your antivirus and you put the program on the white list, else it will always be moved to quarantine. You run it as administrator. When you run it it will say the program is not activated. It will give you a generated serial number, I think it's 3 x 4 digits, total 12 numbers and letters, or may be 16.you can't miss it. Next you will get this code and put it on the activator page , link on ms4x wiki. It then will generate and download a license file. Put it in the same folder as the exe and then run the program as administrator.
 

·
Registered
Joined
·
6 Posts
Hi All,
Got a weird one on my hands. And I thought maybe somebody experienced something similar.
Ms43 mapped by Digital tuning solutions in the uk already.
Ecu won't read through any software. Ms4x flasher cannot identify the ecu. Tried the ecu in a different car, same thing. Other ecu's work perfectly fine.
Even Inpa doesn't read the ecu but car runs perfectly fine on the said ecu.

Has anybody experienced anything similar?
Hi, please did you end up fixing this?
 

·
Registered
2002 BMW E46 330i
Joined
·
208 Posts
Hi, please did you end up fixing this?
I was asked by a guy a while back to tune his ecu. He purchased that ecu from some tuning company I don’t remember at the moment but I had the same issue. I think companies that sell tuned ECUs code in some stuff that makes flash software not recognize the ecu. That way people with their tunes can’t uncover what the companies did for tuning, and with that info sell it off to others for profit.


Mucho fuego es bueno.
 

·
Registered
Joined
·
6 Posts
I was asked by a guy a while back to tune his ecu. He purchased that ecu from some tuning company I don’t remember at the moment but I had the same issue. I think companies that sell tuned ECUs code in some stuff that makes flash software not recognize the ecu. That way people with their tunes can’t uncover what the companies did for tuning, and with that info sell it off to others for profit.


Mucho fuego es bueno.
So there's no way out of the issue ?
 

·
Registered
2002 BMW E46 330i
Joined
·
208 Posts
Unless you know how to code the ecu, not really.


Sent from my iPhone using E46Fanatics
 

·
Registered
Joined
·
6 Posts
Guess so


Sent from my iPhone using E46Fanatics
Hi so i just got a new ecu and I've had someone set it up and everything and now my flasher can identify it.
Ive flashed it and have gotten the bin file and im trying to do a quick pop and bang tune. Please can you direct me somewhere i can get maybe screenshots of tables to edit and maybe the values ?
Thank you
 

·
Registered
Joined
·
1 Posts
Hey the license generation page is down I think. Tells me page isn’t working after I enter hardware ID and press generate license. If someone who know things on computers could fix that I’d appreciate it!
 

·
Registered
2001 bmw 325ci
Joined
·
3 Posts
I have a couple questions, I was was able to download the License file, it worked one time and I was able to do a full flash on my dme. After that it didn't work at all and said it needed to be registered an gave me the registration code for it.
 

·
Registered
2002 BMW E46 330i
Joined
·
208 Posts
I have a couple questions, I was was able to download the License file, it worked one time and I was able to do a full flash on my dme. After that it didn't work at all and said it needed to be registered an gave me the registration code for it.
That’s kinda wierd. You have the license key in the same folder as the flasher right? If the license key and flasher are in different folders it won’t work. Also if by chance the name of the license key was modified it won’t work either.


Mucho fuego es bueno.
 

·
Registered
2001 bmw 325ci
Joined
·
3 Posts
That’s kinda wierd. You have the license key in the same folder as the flasher right? If the license key and flasher are in different folders it won’t work. Also if by chance the name of the license key was modified it won’t work either.


Mucho fuego es bueno.
sorry about the late reply i think it is a glitch. It wouldnt work if it was in the same folder, however i found it to work straight off downloads leaving it in that folder.
 

·
Registered
Joined
·
721 Posts
When I try to open the file after downloading and unzipping the file i get a "File is not a valid format" message.
Im using a Win7/64bit. I used winzip ans xRAR. what am I doing wrong?
 

·
Registered
2001 bmw 325ci
Joined
·
3 Posts
When I try to open the file after downloading and unzipping the file i get a "File is not a valid format" message.
Im using a Win7/64bit. I used winzip ans xRAR. what am I doing wrong?
did you try right clicking it and open with, then select the flasher.
 
181 - 200 of 220 Posts
Top