BMW E46 Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I solved a number of SAP 02 problems this year - replacing the SAP and front 02 sensors
While my car is now running really well, and throwing no codes- I am not getting any of my emission monitors to set . NONE, not after 2,500 miles and 6 months.
No pending codes either. While trouble shooting my SAP and 02 codes this summer most of my monitors would reset / show ready in only a few days of driving.

There was a thread a while ago that may indicate that my problem is somehow in the MODE $06 but it wasn't clear how to navigate through there. I am seeing TID $05 shwing a value of 1220 - the min value is 3932. Other than that, odb fusion isn't showing me any issues.
Car starts drives and stops well. 13.4 V while driving, new thermostat this year and holding at 205F

https://forum.e46fanatics.com/showthread.php?t=1146937

My independent shop believes that the ECU may need to be flashed. I had the car at the dealer at the beginning of the summer for the air bag recall - is it possible that they flashed my DME/ECU?
 

Attachments

·
Registered
E30M3 Race F10 535 R1150Rt M Coupe
Joined
·
2,905 Posts
Odd that the monitors don't run. The components one should set almost immediately.
I think a update and/or reflash of the DME is in order.

No the dealer would NOT have reflashed the DME during any airbag recall work.

The problem isn't in Mode$06. Mode $06 is a place to view/review/monitor specific EPA test modes and witness a value and/or pass/fail result.
The biggest problem with Mode $06 is that ALL the tests for ALL the cars sold in the USA is in there. Knowing which 60% of those pertain to your BMW gets very tricky.
As a BMW TIS subscriber there is an area inside OSS that I can go in and decipher $06 data into real test plans. Problem is that the data is woefully inadequate and support stopped somewhere in the middle of the E46 chassis.

If the car were here in my shop, I just might try a battery reset first before we tried to reflash it.

Does your tool allow you to run an EVAP test? Can you try to force at least that one monitor to see if it takes?
 

·
Registered
E30M3 Race F10 535 R1150Rt M Coupe
Joined
·
2,905 Posts
This article (albeit old) is a decent primer on what Mode $06 is and how it functions:

https://www.motor.com/magazine-summary/advanced-mode-06-diagnostics-march-2007/

As a board member with BIMRS I have pushed for and have had 2 $06 classes taught during our annual training.
Very useful for when all of the normal testing and methods have produced no fruit.
It's daunting and a very grey area for most seasoned technicians. Getting familiar with it and being able to use the tool properly can be useful for us when stumped with an unsolvable Ck. Eng. light.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
Mr MCar, thank you - that link had a lot of detail. Ok that the information is old, these cars are showing their age too.
I'm going to try the battery/hard reset - and pursue the DME reflash if that doesn't prove successful.
the tool i use is OBD Fusion- i don't think i can force it to run the evap test- but maybe the battery disconnect will get it to reset. I'm going to do that tomorrow - i'll fill you in if I am successful.
Again - thankyou!
 

·
Here to serve y’all
2004 330Ci 85k miles
Joined
·
13,184 Posts
I'm going to try the battery/hard reset - and pursue the DME reflash if that doesn't prove successful.
the tool i use is OBD Fusion- i don't think i can force it to run the evap test- but maybe the battery disconnect will get it to reset.
Clearing trouble codes will reset all emissions monitors and re-start the process. I***8217;d do that and watch if any go to PASS on the first drive cycle.

I believe an emissions related DTC will stop all emissions monitor evaluation, so none would move into PASS state at that point. But, you said you see no codes.

I can remotely setup the software and update your DME to the latest if ya like. See the link below for details.
 

·
Ironman
01 330iT 6MT, 98 M Roadster
Joined
·
4,979 Posts
Someone posted a list of those codes published by Range Rover when BMW owned them. I used it to track down and fix an issue. I don't have time to do a deep search, but there are a couple of threads with a link to that file.
 
1 - 6 of 6 Posts
Top