E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
132 Posts
Discussion Starter · #1 · (Edited)
About an hour ago my m3 went into limp mode. I was driving on a wet street and gave car some some extra gas to get through a light. The dsc came on and cut power. A second later, the eml came on and the car went into limp mode. I pulled over and restarted the car. No issues after and I didn't pull any new codes (just the same cat inefficiency codes I've had for several months). Granted I used a generic scanner.

It got me to school just fine after. It was fine on the streets and the highway. I can't seem to replicate the issue but it hasn't been that long.

Any ideas as to what's going on?
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #2 ·
So, the car got me home just fine. No problems on the road or the highway. Is it possible that my DSC is just messing up and triggering limp mode when activated?
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #4 ·
Alright. I'll do that as soon as I get the chance.

Would you be able to tell me where to get the bmw scanner? Can't seem to find any for $10. Just want to make sure I grab the right one.

Sent from my SM-G935V using E46Fanatics mobile app
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #7 ·
Update: It snowed pretty heavily some days ago and the DSC was activated several times. I haven't had any issues since that one time. I also did the hard reset. Now I just need to get that BMW scanner in to check for any hidden codes.
 
1 - 7 of 7 Posts
Top