E46 Fanatics Forum banner
21 - 25 of 25 Posts

· Registered
Joined
·
14 Posts
Discussion Starter · #21 ·
Any update on the above?

If it stops hanging when you disconnect the ABS, then there is something going on with the data the ABS and DME are sharing. ABS trouble codes will be clues.
No trouble codes. DSC appears to function as it should And can be turned off still with the button. ABS functions as it should.
Its been scanned by BMW and another shop, no issues.
 

· Registered
Joined
·
14 Posts
Discussion Starter · #22 ·
I have the exact same situation happening to me too. I sent off my module to have it rebuilt and when it came back and plugged it in like you did it still continued to accelerate for a second or so but not as much as it did before the rebuild. Wondering if you’ve found anything out or not
Still diggin. Forgot to mention that I swapped in two different ABS modules with same results. Found an obscure thread about something in the DME firmware maybe causing the issue so I pulled a different DME from a junkyard car and sent to Kassel for a wipe and re-tune. Waiting on it to come back.
 

· Premium Member
Joined
·
5,128 Posts
well, the throttle hang is an issue...

I'd be looking at data too- as NZ says, the DME THINKS it needs to hold the throttle open,
and it really sounds like it's doing it because of an ABS computer request.
OR unplugging the ABS computer's disrupting the data that the
DME's interpreting as a throttle request.

It's a deep rabbit hole, but then, sometimes the rabbits are at the bottom.

t
with a powder-puff tail
 

· Registered
Joined
·
14 Posts
Discussion Starter · #25 ·
Any news or fixes? My 2003 325xi has the same issue.
Kassel offered to reprogram another DME if I sent it in so I pulled one from another manual trans 325xi I found in the junk yard. Issue is resolved.

I think I have another one that I forgot I’d already pulled if you want it real cheap. It would need a reprogram though. Shoot me a PM
 
21 - 25 of 25 Posts
Top