E46 Fanatics Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello, this is my first post on this here but have always been around here searching for help. I have a 2004 zhp 330i automatic. I have searched this forum many times and have followed advice from many post. My problem however has not been like anyone else. I bought this car 3 months ago not aware that it had this issue. When im driving randomly the car shuts off for a split second and turns back on on its own weather its freeway or city driving. Its as if fuel gets cut off for that short moment. No CEL or warning lights when that happens. about 3 weeks ago car was fine then all of a sudden a trip to walmart and on my way back car starts sputtering and dies. I figure well it was the fuel pump all along and order a new OEM one. Replace it car starts right up and is fine for 3 days. Then again it starts doing the same thing randomly shuts off for a split second. All this happens randomly nothing specific about when it happens. i have swapped relays fuel pump and horn relay to see if it would work. Replaced intake cam sensor. checked all grounds except the ones that i have to remove the seats. Connected PAsoft to scan and clear errors but no errors come up. Disabled the alarm replaced ignition switch checked EWS replaced brake switch. My next step is to replace DME main relay and replace crank sensor. I love this car and would hate to get rid of it but at this point its frustrating me. Just wondering if anyone has any other ideas?
 

·
Premium Member
E30M3 Race F10 535 R1150Rt M Coupe
Joined
·
11,276 Posts
Frustrating for sure. Looks like you've covered most of the usual suspects.

Here's an important distinction: The car sputters to an off condition.
This almost always (not 100%) suggest a fuel related issue. Which can be myriad.

If it were a straight up power supply to the DME issue (Main relay, ignition switch etc.) the car would usually just conk out. Tantamount to pulling the main relay or turning back the Ign. switch.

The fact that it stumbles suggests a fuel related issue. Be it delivery qty. (intermittent ((fuel filter suggestion above)) the fuel pump ground, the fuel pump relay etc.
The rail is full of pressurized fuel, and if delivery stops or wanes, it will take a second or two until it's depleted enough to bring the car to a stall.

I might be looking at fuel pump voltage/ground while driving. (DVOM needed) Fuel pump relay; Relay can open and fuel pressure drops off? Drive with pressure gauge attached to the fuel rail and watch pressure.
(This can be dangerous w/o the attention paid to test hose to hood clearance)

Let us know your findings.
Could also be the freekin DME, but it behooves you to check the above first. If/when you find what's dropping out, the answer/solution should be close at hand.
 

·
Registered
Joined
·
8,985 Posts
connect a test light to the fuel pump 12v and it should be ON whenever pump is running. Use this to monitor the power supplying the pump. Could be an intermittent bad connection.
I doubt a bad cam sensor causing this.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top