BMW E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
229 Posts
Discussion Starter #1
anyone having problems with aftermarket intake?
i put in a cone filter and the sound is nice but then after a while an EML light comes on... then if i take the filter off and let the car rest for an hour.. the light goes off.
anyone had similar problems?
 

·
Registered
Joined
·
1,267 Posts
What cone filter did you put in? Problems like that are usually as a result of improper installation. Check all your hose connections for leaks. Make sure everything is secure. If all else fails, put the stock airbox on and take it to the dealer.
 

·
Registered
Joined
·
229 Posts
Discussion Starter #3
shes at the dealter right now.. no leaks in the connection am i supposed to get a downloadwith it? the way i installed it was to have it down into the stock airbox with the top off usint the stock bottom peice as a heat sheild
what kind do you have?
 

·
Registered
Joined
·
614 Posts
So you didn't remove the airbox? I would have said maybe you damaged the MAF if you removed the airbox hastily but sounds like you didn't. Without the fault codes it's throwing it's gonna be really hard for anyone to assess this. You might need to find someone who has an OBDII reader to find the code and the problem. Most people use one of the following Dinan, DFP, GruppeM, ECIS or Conforti intakes. There are certainly others but those would be most popular ones.
 
1 - 4 of 4 Posts
Top