E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
256 Posts
Discussion Starter · #1 ·
My cluster quit working yesterday day while I was driving, no warning or anything. The needles are stuck where it stopped working. When I got to my destination I shut the car off, when I tried to turn it on again it wouldn't turn over. Wait a few minutes tried again, then it ran.

When I got home I checked fuses, 10, 34 ,43. Nothing. Then I went through all the fuses one by one. Everything checks out. Tried pulling the battery for 10 minutes and plugging it back in, nothing changed. Took out the cluster, waited a few minutes then plugged it back in, I think heard the electronics working, but still no change in the cluster.

I read a little bit about the K-Bus problem but I have no idea if mine is related to that. My steering wheel controls are working, cruise is working, but I don't think my DSC is working at all. :eek:

I do have an appointment to take it in on Wednesday. Anyone else can shed some light on what's going here? :banghead:
 

·
Registered
Joined
·
988 Posts
Hmm sounds crazy:loco: hope you get it figured out!


Sent from my iPhone using BimmerApp
 

·
Premium Member
Joined
·
3,573 Posts
Common K-bus failure can not cause the problems you describe with the cluster so I would disregard that as the possible cause. It sounds like a power problem. Recheck the fuses for the cluster and then check for power and ground at the cluster connector. If you want you can send me the cluster and I'll check it out.
 

·
Registered
Joined
·
256 Posts
Discussion Starter · #7 ·
It wasn't my fuses, I guess my instrument panel just quit working. Over $900 to replace the thing. I hope this doesn't happen to anyone else. What a freak problem. :banghead:
 
1 - 7 of 7 Posts
Top