E46 Fanatics Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
781 Posts
Discussion Starter · #1 ·
This is a clickbait title, got ya!

Anyway it appears that the cold weather has finally made its mark on my lcd’s.

I’ve had this rig since Aug of ‘17 and I’m used to the clock and The hvac lcds having a bit of a problem during really cold days, the thing is the pixels usually fix themselves after a couple minutes of driving with the heat on.

however this time is different. It appears that my luck has run out, as it’s been almost 7 days now and the pixels in my hvac display aren’t fixing themselves!

it was bound to happen sooner than later I suppose considering how old this module is……but what exactly went wrong that has infested this modules lcd?

Fortunately a replacement is no more than $20 off of eBay. But can the existing unit be fixed in a way that is worth less than $20 to solve the headache?
 

Attachments

· Registered
Joined
·
210 Posts
I don't think they can be fixed less than a used replacement. One of my pixels went out this year and I just got a used one to replace it.
 
  • Like
Reactions: Hot_tub

· Registered
Joined
·
4,082 Posts
Fortunately a replacement is no more than $20 off of eBay. But can the existing unit be fixed in a way that is worth less than $20 to solve the headache?
Just make sure you buy a replacement that matches (or exceeds) the SW version you currently have. I replaced my HVAC Control Panel that has SW 007.0 with a unit that came from a 2000 E46 and although it functioned just as it should in a 2000 E46 (SW 005.0), it didn't function like the one I removed from my 2002. I'd venture a guess that you want a replacement with SW 007.0 or later.
 

· Administrator
2013 X1 M-sport
Joined
·
22,464 Posts
it's not like the E39, where they're all bad
The E39 MID units are usually fine, it’s the zebra cable connection that needs fixing on most of them. Tomas has repaired many for me over the years.
 
1 - 7 of 7 Posts
Top