BMW E46 Fanatics Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
28,945 Posts
Discussion Starter #1
OK, guys my car has the wierdest quirk ever...

I put on my Hamann exhaust and the day after doing so my car has on three different occasions seemingly stalled out while driving. What seems to happen is that when I shift gears from say second to third at thirty five miles per hour (*or fast or slower speed and rpms don't seem to make a difference) the rpms will suddently drop down to zero, the powersteering turns off **(i almost crashed the first time it happened because I was going around a turn as it did such), the check engine light in addition to the oil light and battery light turn on and everything else (radio, interior lights) seems to be fine.

Does this sound as though the car is stalling? Would the exhaust be the culprit (*my friend had an alfa romeo that did this the problem ended up being the fuel pump)... do you guys think its the fuel pump/exhaust/what? If I take it to the dealership (the car still has its warranty but now has a Hamann exhaust on it) do you think they will blame it on the exhaust and basicly tell me that I'm out of luck and that they won't fix it under warranty? Should I take the car to Midas (where I had the exhaust installeD) and see if they have any ideas? Should I take the exahust off, put the stock one back on, take it to the dealer, and tell them that the car has been acting up lately and see if they find anything wrong with it? What do you guys suggest...

Could puting an ECIS intake and a Hamann exhaust actually have done something wrong to my car (I did buy the exhaust used). Do exhaust systems go bad after a certain millage (mine had 15k miles on it from the previous owner).

What do you guys suggest... I'm in a real bind... That being said, the exhaust does look sick :woot:

Please help! :(
 

·
Registered
Joined
·
28,945 Posts
Discussion Starter #2
somebody please help me out with this one.
 

·
Registered
Joined
·
28,945 Posts
Discussion Starter #3
please??? :dunno:
 

·
No more E46 :(
Joined
·
2,671 Posts
:rolleyes:

Would you please stop bumping? This is, after all, Saturday morning and most people are either out partying or asleep...
 

·
Registered
Joined
·
125 Posts
Before I'd go to the dealer I would definately go back to where you had it installed. They might have some Ideas. I've never heard of this problem before. It sounds like it could be the exhaust.....that's just weird.
 

·
Registered
Joined
·
156 Posts
Idle and stalling issues often have to do with vanos problems. Especially on 1999-2000 e46 cars. I don't think your exhaust or your intake has anything to do with it. Just a coinsedence that it happened at the same time. Go back to the shop where it was done and have them check it out. You may have an exhaust leak or a leak at the intake. :dunno: If not, off to the dealership you go. :thumbdwn: Vanos problems are very expensive if you don't have warranty. :bawling:

ABE
 

·
Registered
Joined
·
17 Posts
Based on the details you provided. I highly suggest you take it to a shop or an Auto Zone to have the computed scanned by an OBD-II scanner. Since you did mention the check light came on. Guessing and speculation will not get you closer to the root cause, my 2 Cents..............
 

·
Registered
Joined
·
28,945 Posts
Discussion Starter #12
Alright,
Well I think I will take it over to Midas, and have them check the exhaust bearings, vanos, cam sensor, and the cars computer... if they can't find anything I'll take it over to the dealer.

Do you think the dealer will say that the exhaust caused the problem and will refuse to fix it through my warranty.
 

·
A bimmer chick moderator :)
Joined
·
48,236 Posts
only way for them to refuse to fix under warranty is if they prove that the aftermarket exhaust is causing the problem...
 

·
No more E46 :(
Joined
·
2,671 Posts
2000_328CI said:
Alright,
Well I think I will take it over to Midas, and have them check the exhaust bearings, vanos, cam sensor, and the cars computer... if they can't find anything I'll take it over to the dealer.
Dude, there is NO exhaust bearing!!! :lmao:
 

·
Registered
Joined
·
28,945 Posts
Discussion Starter #16
OH ok, well what should I say could "possibly" be causing the problem.
 

·
Registered
Joined
·
1,227 Posts
your problems have nothing to do with your exhaust, do the lights just come on when it stalls or do you have a SES (service engine soon) light on all the tirme. If you do scan the code and we can help you out better. Be sure to write down all of the Pcodes.
 

·
Registered
Joined
·
28,945 Posts
Discussion Starter #19
Service engine soon isn't always on.... rather the oil light, battery light, and check engine light come on when it stalls.
 
1 - 20 of 27 Posts
Top