BMW E46 Fanatics Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
267 Posts
Discussion Starter #1
Hello fellow E46fanatics. Somebody broke into my car and stole the cluster from my 330Ci. There are two that plugs that goes into the cluster. One of my wiring harnesses(18-pin white) was cut. I went to the dealer and bought the plug/wiring kit to repair the one that was cut off. They couldn't help me with the print out of the pin assignments. I have been Googling and can't find anything. I even used the BMW software and couldn't find it.

So my last resort is, could one of you help me out by removing the two screws to your cluster and taking a picture of the 18-pin white plug? I need a picture behind the plug to see what color goes into which pin. There should only be 4 wires going into that plug even though its a 18-pin plug. Any help would be greatly appreciated. This has been holding back my resort project for a long time now and it would only take a few minutes of your time. Thanks again
 

·
Registered
2001 E46 330i Sedan
Joined
·
349 Posts
Tell us what color of those cables are and probably I can help you identify which cable goes where. My car is not the same as yours.
 

·
Registered
Joined
·
2,776 Posts

·
Registered
Joined
·
267 Posts
Discussion Starter #6
Yes I have and I couldn't find what I was looking for. I did this buy looking at the "A2 Instrument Cluster" which could be found by using the search on bottom left corner.
 

·
Registered
2001 E46 330i Sedan
Joined
·
349 Posts
Thanks, the wiring colors are:

Yellow/Red
Brown/Green
Blue/Red
Blue/Brown
Yellow/Red - GE/RT - Pin 13 - Turn Indicator
Brown/Green - BR/GN - Pin 4 - WindScreen Washer level
Blue/Red - BL/RT - Pin 1 - Outside temp sensor +ve
Bleu/Brown - BL/BR - Pin 2 - Outside temp sensor ground

You can confirm this with WDS - you probably didn't see the color code on the diagram when you looked last time.
 

·
Registered
Joined
·
267 Posts
Discussion Starter #8
Thanks for the response, which diagram are you looking for this? The A2 cluster section has many diagrams and I would to see what you're looking. The diagrams are some what confusing as there could be the same wire color used in different pins but it depends also on size of wire?
 

·
Registered
Joined
·
267 Posts
Discussion Starter #10
Hey Scott, its Simon. I installed the GM5 unit you sent to me yesterday. Everythings working like it should again, thank you.

This is another reason why I am confused as zbi701's wiring/pin posted is different from your site. I am trying to figure out which diagram zbi701 was looking at to check if its for my body build. The dealership should have all this information for me but they couldn't help me. I should try another dealership.
 

·
Premium Member
Joined
·
3,537 Posts
Hey Simon, I'm glad the door locks are working again.

Regarding the wiring. Try this. Go to the WDS. I typically use http://www.bmw-planet.com/diagrams/release/en/e46/index.htm
Then click, "Component and signal information", "Components", "A_Control units, modules", "A2 Instrument cluster control unit". Now your car is probably very similar to the 14th one down, "A2 Instrument cluster control unit (DME Motor Electronics MS54 with DSC Dynamic Stability Control MK60 up to 2002_09"
It shows 6 wires on connector X11176 for a non-convertible. 1,2 for the outside air temp sensor, 4 Washer fluid level, 13 for the BC switch on the turn signal stalk, 14 for the Gong (audio beeper) and then 7 for reversing signal which is only present on some vehicle. None of these signals are critical to the operation of the car so you can drive without them connected.
The colors codes are in german abbreviations. Use my web site to decode them as well as to decode the wire gauge equivalents.
 

·
Registered
2001 E46 330i Sedan
Joined
·
349 Posts
This is another reason why I am confused as zbi701's wiring/pin posted is different from your site. I am trying to figure out which diagram zbi701 was looking at to check if its for my body build. The dealership should have all this information for me but they couldn't help me. I should try another dealership.
I was looking at the exact diagram that Scott mentioned above. Just ignore the 2 wire that you don't have on your car.
 

·
Registered
Joined
·
267 Posts
Discussion Starter #13
Updates:

Tried the above suggested wire colors from zbi701/Scott and noticed nothing. The cluster still shows "--:--", the windshield wiper light is still on, and the push button on the left stalk has no response. Same as if I had the harness unplugged. Any other ideas guys? Could somebody take a picture of their Pin out just to see?
 

·
Premium Member
Joined
·
3,537 Posts
Updates:

Tried the above suggested wire colors from zbi701/Scott and noticed nothing. The cluster still shows "--:--", the windshield wiper light is still on, and the push button on the left stalk has no response. Same as if I had the harness unplugged. Any other ideas guys? Could somebody take a picture of their Pin out just to see?
The cluster shows --:-- because you need to set the clock. Use the right instrument cluster knob and twist.

I just took pictures of the X11176 (18-pin connector) on my car, 1999 4-dr auto transmission and this is what I got.
Pin 1 - Blue-Red Stripe - Outside temp sensor
Pin 2 - Blue-Brown Stripe - Outside temp sensor
Pin 4 - Brown-Green Stripe - Washer fluid level
Pin 12 - Blue-Black Stripe-Yellow rings - Drivers seat belt
Pin 13 - Yellow-Red Stripe - Turn signal stalk pushbutton

Which matches my wiring connection web page that I posted earlier. Just ignore the stuff that doesn't match your car like manual trans, convert, M43 engine, etc.



When inserting the connector housing into the bail lock assembly observe the arrow direction of the arrows on the housing. If you get that wrong pin 1 will be connected to pin 18, 2 to 17, 3 to 16 etc.
 

·
Registered
Joined
·
267 Posts
Discussion Starter #16
Update:

Everything works now. Thank you all for taking the time and effort into helping me. I can finally take the car to the dealer for coding. Thanks again
 

·
Registered
Joined
·
1,060 Posts
Holy. :excited: :yikes: :woot:

I have had my car for 7 months and have lurked on these forums for over a year, and I have never seen any reference to this site. I am not going to get any sleep for the next week while I study every diagram on here. :woot:

Someone needs to add this to a sticky.
 
1 - 18 of 18 Posts
Top