BMW E46 Fanatics Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
2,270 Posts
Discussion Starter #1
Hey everyone!

So I a few days ago I got the traction control and yellow brake light that will not go away.

Initially I scanned with a Foxwell scanner and got 5E21 and 5E26 error codes. Based on those codes a few people suggested changing Pressure Sensor 2 (error 5E21) on the brake master cylinder.

Searching this forum shows 5E26 related to the Yaw Sensor and refers to a electrical fault (I think). Not sure how to address that one.

Today I connected INPA and got error codes in the Steering Angle Sensor, DSC MK60 and ZKE module (not sure if that last one is related).

Rather than trying to reproduce the errors here i will attach screenshots of them.

I also had an error in the IHKA and DMTL but no check engine light. So I'm not sure what that's about. Any suggestions are appreciated.

If anyone could take a look at the DSC codes that would be great!

Thanks and have a great day! :bow:
 

Attachments

·
Registered
Joined
·
2,270 Posts
Discussion Starter #2
Error in DSC MK60

photo of the MK60 error. Not sure that's a valid error.
 

Attachments

·
Registered
Joined
·
2,270 Posts
Discussion Starter #3
ZKE error.

Not sure if this is part of the ASC/DSC errors.

ZKE:
 

Attachments

·
Registered
Joined
·
2,270 Posts
Discussion Starter #4
DMTL and IHKA errors

Would the DMTL error cause high Fuel Trims? :banghead:
 

Attachments

·
Registered
Joined
·
7,493 Posts
did you recalibrate steering angle sensor and check wheel speed sensors?

vids on youtube i'm pretty sure

i had trifecta , i pers don't pay much attention to the codes in inpa

i use 1.4 for reading codes and inpa more for diag

was a bad wss in my case

i recalib the sas first tho anyway
 

·
Registered
Joined
·
2,270 Posts
Discussion Starter #6
did you recalibrate steering angle sensor and check wheel speed sensors?

vids on youtube i'm pretty sure

i had trifecta , i pers don't pay much attention to the codes in inpa

i use 1.4 for reading codes and inpa more for diag

was a bad wss in my case


Is that accomplished by turning the wheel lock to lock? Or is there a different procedure?

I haven’t tried anything yet.
 

·
Registered
Joined
·
7,493 Posts

·
Registered
Joined
·
7,493 Posts
this is a good vid

https://www.youtube.com/watch?v=k6bEmK60bh8



far as wss , it's in there you gota find it , then just roll the car backwards in reverse and watch the values of all 4 , you'll see if one is bad, i did it in literally 10 ft or so


if after checking them and recal steering you still haven't found issue , then you either have a bad brake pressure sensor , there are 2 on the master cylinder

or

you have a bad dsc module



you may have other issues , but as far as the trifecta that's all i can offer , i didn't have to get into abs so somebody else will have to take over
 

·
Registered
Joined
·
2,270 Posts
Discussion Starter #9 (Edited)
Well, lights are off after letting it sit for 2 days. Go figure. But it looks like #2 is going bad:

Brake pressure sensors: as you can see Number 2 is almost into the red range at 4.9.

I guess this means I should just replace sensor 2?

Also wheels speed, yaw, and steering angle all seemed to be working fine when I watched them live in INPA.


Sent from my iPhone using E46Fanatics IMG_1792.jpg
 

·
Registered
Joined
·
7,493 Posts
looks that way , but i'm not an abs expert , maybe wait for more replies


i know it's a mf to get in there at them
 

·
Here to serve y’all
2004 330Ci 85k miles
Joined
·
11,575 Posts
I would put off the ZKE (general module) and IHKA (heating/AC module) and DMTL codes until later as those are just annoyances. Address all those once your ABS module issues are solved.

Use translate.google.com for the German text, then Google the error code with its English text.

My gut instanct tells me it's a bad ABS module, because you see unrelated signals gone when viewed in INPA. But that's just speculation on what I see so far. When you get an ABS module error code, look at its related live data and see if it's valid. If it's totally gone, that's often a bad ABS module; internal wires, solder joints, components, go bad and typically open a circuit. Unfortunately, the MK60 is not really rebuildable. So you buy a used one from a newer E46 (2004+), install it, bleed, code it to your car, calibrate steering angle sensor, etc. There's been a rash of these on this forum the last couple months. It may also be wiring or a connector, so inspect those carefully.

Text me if you want to do a live troubleshooting session. :hi:
 

·
Registered
Joined
·
2,270 Posts
Discussion Starter #12 (Edited)
Thanks Bali! I think the #2 pressure sensor is on it way out!

As you can see it was almost out of range. I just want the DSC system to work while I’m driving.

I work the next three days but I’m off Thursday. If you’re available we can remote. I need to update my engine and transmission software as well if you’re available.

I have your number so we can chat. I’ll text you Wednesday.


Sent from my iPhone using E46Fanatics
 

·
Here to serve y’all
2004 330Ci 85k miles
Joined
·
11,575 Posts
Thanks Bali! I think the #2 pressure sensor is on it way out!

As you can see it was almost out of range. I just want the DSC system to work while I’m driving.

I work the next three days but I’m off Thursday. If you’re available we can remote. I need to update my engine and transmission software as well if you’re available.

I have your number so we can chat. I’ll text you Wednesday.
Sounds good. I think I’m free all day Wednesday.

I believe there are two pressure sensors. Maybe you can swap them and verify it’s the sensor and not the wiring or ABS module? Fair warning: it’s a PIA to get to.
 

·
Registered
Joined
·
2,270 Posts
Discussion Starter #16
New sensor is in and error lights are out. There's some pix and a short writeup here:

 
1 - 16 of 16 Posts
Top