BMW E46 Fanatics Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Received this yesterday. Thought it was a simple plug and play with the cd changer inputs in the trunk. But I'm not able to get it to work. Here are some background specs. I have the classic 5gig ipod, 2jl amps (one for speakers, one for sub). From what I can tell the connection is not working. The ipod is not being charged and I'm not able to find it on the radio display when I hit the mode button. Is there something that I'm missing? I would think this would work the same as the blitzsafe et all applications. Does it matter that I am using aftermarket amps? The head unit is oem. I have a 2002 325ci, no nav. I'm including pics. The blurry one is of the two cd changer inputs that I'm using. Any help would be appreciated. Thanks.





 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
I had to send it back and get a replacement. It should be here before Christmas. I'll let you know if it works. There is another thread in the ICE section where someone got the ice link to work - no problems. Take a look at that.
 

·
Banned
Joined
·
1,703 Posts
hey buddy, di dyou have to buy the RC-87 or whatever cable? Can you show me a picture of that? I am just wondering because I just bought one too. Also, which mount did you use?

AdamR
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
I do not have my replacement unit yet, so I have not installed it. Here is a link to the cable RC-87 . I'm not sure if I'm going to use a mount to hold the ipod. I'm going to leave it in my trunk until spring. It's cold as hell here right now. I'll do a proper intall when it's warm.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #6
Just got my replacement ice-link in. Hooked it up using the instructions and this time it worked. If you're doing this, make sure you disconnect the battery first. Now I just need to find the right volume settings on the ipod and the bmw radio. From the few songs that I listened to, the ipod sounds great. And I can use my steering wheel buttons too. Now I just have to get the extension cable and run it into the center console.
 

·
Banned
Joined
·
1,703 Posts
:bump:

I still have not recieved mine yet and just try getting in touch with the people at dension usa. Their telephone system sucks A$$.... you cant even hear the prompts and when you try to get someone on the line you just hear a lot of clicks in the background and nothing else... dont know if a phone is ringing somewhere or not.... So far I am NOT liking this company one bit.

AdamR
 

·
Registered
Joined
·
18 Posts
Discussion Starter #8
I didn't have any luck with emails either. Yes, their phone system needs to be improved. I've only not been able to get a hold of them one time. The other times the same guy answered the phone. This must be the only guy there working the phones. I always called around 3-5pm est. They are a CA company, so just keep the time change in mind if that applies to you. Other than that, I don't know what to tell you.
 
1 - 8 of 8 Posts
Top