BMW E46 Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter #1
Just a moment ago when I was driving my car, the oil temperature goes up so rapidly and the gauge hit the red line. I have seen the indicator for the coolant turned on whenever I started the car in the morning. but it went away after I drove 5 mins.
Is the coolant leaking? Any other problems which can cause that? My car is 3 yrs old with tons of milege (80k miles).

Thanks for any advice
 

·
Registered
Joined
·
580 Posts
Did you install a separate oil temp guage? Standard guage reads
water (coolant) temp and if you hit the red something is wrong. You're probably significantly low on coolant which may be caused by a leak or maybe you just haven't topped it up in a looong time? Let engine cool down then check level per manual and top up as necessary with 50/50 BMW coolant mix then get the car back up to operating temp and check for leaks-hopefully you won't find one. Good luck
 

·
Registered
Joined
·
122 Posts
Discussion Starter #3
I think I haven't added coolant for a long time as my last service was long time ago
What is the color of the old coolant?
 

·
Registered
Joined
·
218 Posts
check ur fluid its probably leaking and ur running with no antifrezze at all , try not to drive it or your going to damage ur engine also make sure ur fan turns , u can also have a bad fan motor
 

·
Registered
Joined
·
580 Posts
BMW coolant is green however do not substitute with just another green antifreeze, get the BMW stuff from the dealer
and cut it 50/50 with triple distilled water for top-ups-better yet have the dealer flush and replace with 100% fresh stuff if you don't feel confident doing it yourself. Could be that fan is dead but then why does he also get low coolant indicator on start-up? It could be both but that would be a very unfortunate coincidence!
 
1 - 5 of 5 Posts
Top