BMW E46 Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello everyone.

I need help. I tried the search function but it was of no avail.

Problem:
Engine light came on... Car (2002 330i) stutters and feels like if it is going to turn off on idle. When I drive, car is not responsive and accelerates at a slow rate. I step on the gas pedal but car won't speed up like it should- It speeds up, more like constant but slow until it reaches the speed I want to go!!

So, now car is in my garage.

What could the problem be?

I visually checked the hood and the underside but did not notice anything abnormal.

Any help would be really appreciated.

Has anyone experienced this problem?

Thank you, for reading.
Joey
 

·
Registered
Joined
·
2,277 Posts
Hello everyone.

I need help. I tried the search function but it was of no avail.

Problem:
Engine light came on... Car (2002 330i) stutters and feels like if it is going to turn off on idle. When I drive, car is not responsive and accelerates at a slow rate. I step on the gas pedal but car won't speed up like it should- It speeds up, more like constant but slow until it reaches the speed I want to go!!

So, now car is in my garage.

What could the problem be?

I visually checked the hood and the underside but did not notice anything abnormal.

Any help would be really appreciated.

Has anyone experienced this problem?

Thank you, for reading.
Joey

Joey, first and foremost...GET THE CODES PULLED!
 

·
Registered
Joined
·
1,247 Posts
dude codes checked

run the codes on the search bar and bam answers

just desrcrbing it isnt going to do anything...misfire, cam sensor, vacuum leak it could be alot of things...go to autozone its free and youll know more or less what it is
 
1 - 7 of 7 Posts
Top