E46 Fanatics Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
151 Posts
Discussion Starter · #1 · (Edited)
Is anyone else having a ***** of a time putting the red rubber coupler onto the Gruppe M? Five minutes to take out the stock airbox, ten minutes to put the new filter together, and forever to slip on the coupler, which is still unattached. Nice engineering! Perhaps it'll look nice on the mantle, because it's impossible to get in the car.
 

·
Registered
Joined
·
151 Posts
Discussion Starter · #3 ·
Thanks, Clem. I have tried a hair dryer, hot water, lubricant, stretched it out with a cylinder and I still cannot get it to slip on. It's inner diameter is a smooth fit on the MAF, but it is fractionally too small to fit on the CAI.

Also, did you have to pay sales tax as a non-CA resident and did yours come with a recharge kit?
 

·
Registered
Joined
·
151 Posts
Discussion Starter · #5 ·
I'm trying boiling water next and I'll try the window cleaner things. Thanks.
 

·
Registered
Joined
·
2,479 Posts
tcutter said:
Is anyone else having a ***** of a time putting the red rubber coupler onto the Gruppe M?
It's far too cold in our neck of the woods right now. It warmed up today and highs are near 60 for the weekend. Try it then and you should have better luck.
 

·
Registered
Joined
·
151 Posts
Discussion Starter · #10 ·
Uh, I'm inside putting it together. Do any of you have the '02 325 version with the red coupler, or am I the only lucky one?
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top