BMW E46 Fanatics Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
348 Posts
Discussion Starter #1
Ok, here's the situation... Please let me know what you think.

While driving on Sunday, out of the blue, my car started acting up. When I pushed on the accelerator, the engine would get real rough, there was a dull thud sound every time the engine turned. I could also feel the sound through the gas pedal. If I gave gas, the thuds just got faster and more pronounced.

I looked at my cluster, and the service engine soon light had came on. So I pulled over, extremely frustrated, put on the hazards and let the car sit for a minute or two. I didn't have my cell with me so I decided to start the car again and see if the problem had fixed itself. The car started up like normal, and ran smooth. I thought all was well?

Today on my way to work, the same thing happend on the freeway. I had to exit from the fast lane trying to give as little gas as possible to keep the thudding down. When I finally got pulled over and restarted the car, it ran smooth again.

Now I'm scared, what do you think it could be? Could it be caused by my Gruppe M intake? Should I put the stock intake back on before bringing it to the dealer?

Please Advise!:banghead:
 

·
Registered
Joined
·
348 Posts
Discussion Starter #2
Please? Sorry for the 1 hour bump, but this is really making me nervous.
 

·
King of Useless P O S T S!
Joined
·
2,321 Posts
Hope it's nothing serious, but yeah, since you still under warranty (I'm just assuming), put the stock intake back on just to be safe.
 

·
Registered
Joined
·
348 Posts
Discussion Starter #5
Thanks guys, anybody know what might be wrong?
 

·
Registered
Joined
·
348 Posts
Discussion Starter #7
Thanks shicks,

On rennsport forums someone said it is probably the cam positioning sensor.

whatever it is, I hope it's not a huge pain to get fixed.
 
1 - 8 of 8 Posts
Top