E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
Whenever i push down on the passenger side of the hood this a squeaky noise keeps coming. I recently replaced my rear struts since one was bleeding out. But i am not sure whether the noise is coming from the strut itself or the mount, spring or something else thats around that general area.

Here is a video of the issue,
http://www.youtube.com/watch?v=g0x31lcF5q4

Its a 2001 330ci
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #3 ·
I checked, there is nothing rubbing. Im beginning to think that it's the strut. I sprayed some WB40 on everything metal but the sound is still there. it isn't coming from the top, as in where the mount is.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #5 ·
Are you talking about the top most part of the mount? as in where the strut is connected to the body? or are you talking about the strut itself?

What i am trying to figure out is, should i take it apart and grease it or can i do it while its fixed on to the car?

thanks..
 

·
Registered
Joined
·
2,891 Posts
Are you talking about the top most part of the mount? as in where the strut is connected to the body? or are you talking about the strut itself?

What i am trying to figure out is, should i take it apart and grease it or can i do it while its fixed on to the car?

thanks..
Talking about the strut itself , the upper mount has no rubber components , it's just a bearing and a "cup".

Another part that could make this noise would be the spring on the spring perch(i believe this is the english name for it) , rotating the spring could help if that is the case.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #7 ·
Alright.. thanks for the input. tomorrow i will take out the wheel and have a closer inspection. i will post some pictures and maybe a video about what i find.

Usually I use ramps to go under the car. i have a jack and a pair of jack stands, its going to be hell finding out the proper jack points to lift it up. The last time i lifted it up i left a small dent!!
wish me luck..

kasun.
 

·
Registered
Joined
·
3,322 Posts
It could be the strut itself. Spraying WD40 on a strut is not a good idea. How many miles on it? It could be the lower ball joint on the control arm. Mine groaned when failing. By the way the strut mount does have rubber and a bearing which can make noise. But my bet is on the ball joint or possibly a tierod.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #9 ·
The noise does not come when the vehicle is in motion (whether i am going straight or taking a turn). On occasion when the vehicle is about to come to a complete stop i could hear the noise coming from the passenger side wheel area as the car is leaning forward for the stop. I did get my control arm replaced on that side after bumping into the pavement last year. And i am sure that the ball joint was replaced, ill check on that today. I am about to have a closer look, ill post what i find out within the next couple of hours.

I have 150,000+ miles on the car. I got my rear shocks replaced. Im guessing i have nothing to lose by replacing the front stuts.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #10 ·
I just found out that I have a torn rack and pinion boot. Which is another issue, this isn't causing the noise. But I ordered the part and when it gets down which should be within this week, I'll post some videos.

Does anyone have any idea how to clean the dirt that is in the boot? And what sort of grease to use? Thanks
 
1 - 10 of 10 Posts
Top