BMW E46 Fanatics Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1 (Edited)
2000 328ci

So I replaced 4 rotors / pads / parking brake shoes about 3 months / 1000 miles ago.

Pads/rotors are the ebay junk slotted/drilled rotors etc. I think the pads were PBR or something, green box. Parking brake shoes are oem from dealership.

Everything was working fine. The other day I was headed home from a park at the top of a hill. Downhill was maybe 3 miles or so. Halfway through my brakes started to feel really weak, then I smelled the brakes. I started going slow giving myself a lot of distance between the cars in front of me, brakes were really weak, took a lot longer distance and more pedal effort to come to a stop.

When I got home took a quick look at the pads through the wheels, front pads looked like they were not flat against the rotor? Like a piece of the pad material was missing/broke off? Pads are supposed to be pretty much flat against the rotor surface correct?

Rear pads looked fine, pretty much flat against the rotors, both front pads looked like they had a chunk of pad material missing.

Could it be the pads were junk, and going downhill made the pads hot and killed them? I know slotted rotors can eat pads, could that be the problem with the downhill?

My old oem pads still had a good amount of life left when I removed them, can I just reinstall those pads only if my current pads are missing a chunk? Haven't had time to remove the pads completely yet.
 

·
Registered
Joined
·
5,409 Posts
Pics...Will tell use a thousands words...
 
1 - 2 of 2 Posts
Top