BMW E46 Fanatics Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
First and for most, I'd like to thank this forum and it's members for the wealth of information.

After much reading I decided to buy a 2001 325i, 5 speed, with 127,000 last setpember. Car now has 141000.

Parts replaced. All parts were replaced with oe or oem quality.

-coils and plugs
-ccv and all hoses
-both precat o2's
-maf sensor
-intake and exhaust camshaft sensors
-crankshaft sensor
-disa valve, rein brand
-watetpump, thermostat, hoses ect.
-vanos seals
-valve cover gasket
-fuel pump and filter
-fuel sending unit (mine was unplugged when I opened that side of the gas tank, check before you buy the part it's fast and easy)
I could go on and on but I think that covers the engine parts.

During my drive to North Carolina last Easter. Doing 80 on the highway my sel light came on and the car started misfiring. I could tell the car shut off a few cylinders. Luckily I had my obd2 plugged in and was able to clear the codes via my cell phone. After the codes were cleared the car ran great and made it the 150 plus miles with incident.

While at my brother's house I checked a few things, included torquing the spark plugs to 22 ft pounds. Everything seemed fine. On the way home a, 300+ mile trip, it throw the same codes again, twice! I had no choice but to clear the codes and keep truckin.

The codes were for random multiple misfires across all cylinders some with fuel cutoff. The strange part is I can't find anything wrong with the car.

-fuel trims are good. A little rich at idle but I've never seen the long term go +/- 2.
-o2 sensors switch back and forth and respond the way you would expect from throttle input.
-I have never had a lean code, I've checked for vacuum leaks several times and only found one cap(back side manifold)leaking which was replaced. Had to jbweld my valve cover but it no longer leaks.

The only other issues with the car are,
-hunts for idle sometimes
-sometimes idle drops low coming to stops, car shutters and then picks back up.
-if you try and hold a low rpm under 1300 the engine won't hold steady, keeps fluctuating low then high.
-either has a lifter making some noise or a very small exhaust leak.
-I believe the flywheel has started to chatter here recently.

I'm just at a loss for what could be causing my random misfires. I've read the the battery plays a big part in these cars. The battery that's in the car is a h6 size seems a little small bit after sitting over night still has 12.45 volts. I might just buy a new icv and see what happens. I'm just a little tired of throwing money at this car. I have motorcycles that need the attention this time of year. Anyone have any thoughts, I'm open to all suggestions. Thanks.
 

·
Premium Member
2003 330cic, 2003 325iT
Joined
·
3,936 Posts
If I were in your shoes I would have a smoke test done by a shop. One of the issues in finding the leaks is that some are under the cabin air filter or low on the engine and hard to spot. But if your LTFTs are +/- 2.0% then that is spec.

I would double-check that the O2 sensor plugs were matched correctly. I plugged mine in backward when I replaced them - no, I am not the only one... ;)

What brands of O2 sensor, fuel pump and MAF sensor did you buy? Did you get them new? Not trying to ask a stupid question, but I do notice people get "good" used sensors from junkyards, and it is really hard to know if something like a used MAF sensor is good. The consensus seems to be Bosch for O2, VDO/Siemens for MAF and pump.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3 (Edited)
I have smoke tested it myself several times my self using the cigar and transfer pump method, only found one leak which was fixed. Plus the fuel trims don't show a lean condition.

I made sure the o2 sensors were wired correcrly ( unplugged bank1 and bank1 stopped reporting. The o2s were new Bosch.

Fuel pump and mas both new vdo from fcpeuro.

I check compression the other day all cylinders between 180 and 170.
 

·
Premium Member
Joined
·
28,970 Posts
My bet is restricted catalytic converters. We are seeing this more and more as these cars age. You need to be VERY careful when you measure exhaust back pressure and assume if you are not over 1.5 PSI at idle you are fine. The street "spec" is VERY wide and IMHO too broad.

https://forum.e46fanatics.com/showthread.php?t=1247755
 

·
Registered
Joined
·
1,174 Posts
I would just replace the plugs for pm, and too get a better look at the coil plugs etc. make sure the ground wire didn't break or anything. I'd also take a very close look at all the CCV and vacuum components again. I had the same type of problem as you before, turned out to be a broken dipstick drain hose. Also a very good idea to replace the intake boots anyway
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Thanks for all the replies, I really appreciate it.

I will order the exhaust pressure tester on amazon tonight but won't be able to test till next week.

So, anything above 1.5 psi at idle is considered restricted? Would it be worth just bitting the bullet and installing the eBay headers I got for Christmas last year? Good excuse to take a three day weekend.

Plugs and coils have less than 10,000 miles, I know that doesn't mean they are good but I belive if a coil or plug was bad the problem won't be so intermittent.

Ccv is new as are both intake boots. When I bought the car I replaced just about everything this and other forums said were common to fail. I almost certain the car doesn't have a vacuum leak. Trims are a little rich if anything.

I tested the voltage at the battery. Im thinking I'll just get a h8 battery from Walmart there only 150 dollars.
 

·
Premium Member
Joined
·
28,970 Posts
Understand that 1.5 PSI back pressure at idle is not actually a value you should be focused on. The PROBLEM is the general pressure values on the "street" are generic and often are only taking into consideration a single converter.

I do not know what a "good" E46 back pressure value is, but it is probably below 1 PSI at idle, maybe even under 1/2 PSI at idle.

Be careful what gauge you get, the larger in diameter the better and even better if the max pressure value on the gauge is like 8-10 PSI.

I am almost of the midset to NOT suggest people consider testing the back pressure because they see under 1.5 PSI and think everything is fine when it is really not!

Suggest you take some time and really read through these threads:

https://forum.e46fanatics.com/showthread.php?t=1247755

http://forum.e46fanatics.com/showthread.php?t=1123756

http://forum.e46fanatics.com/showthread.php?t=1086200

https://forum.e46fanatics.com/showthread.php?t=1242285
 
1 - 8 of 8 Posts
Top