BMW E46 Fanatics Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1 (Edited)
Hello readers,

I have the following problem.

First of all im not a technician. I have some problems on my bmw e46 ci 1999. I recently cleaned my maf with breake cleaner. These errors am i getting especially when i dont drive (engine is running but car is idle)

E R R O R M E M O R Y R E P O R T
-------------------------------------
Date: 11/01/10 14:19:25
ECU: MS420DS0
JobStatus: OKAY
Variant: MS420DS0
-------------------------------------------------------------
RESULT: 7 errors in error memory !
-------------------------------------------------------------
45 multi funktion steering wheel supervision interface
Error frequency : 1
Logistic counter: 40
Engine speed 704.00 1/min
Battery Voltage 14.08 V
Speed 0.00 km/h
temperature cooling water 90.00 Grad C
appear before (rel.) 0.10 h
Toggelbit Periode fehlerhaft
Fehler nach Entprellung gespeichert
Fehler momentan vorhanden
statischer Fehler
Errorcode: 2D 68 01 28 16 8A 00 B8 6C 05
-------------------------------------------------------------
227 lambda contol tolerance Bank 1 to big
Error frequency : 1
Logistic counter: 40
Engine speed 736.00 1/min
load 59.92 mg/Hub
temperature cooling water 96.75 Grad C
lambda contol tolerance Bank 1 23.82 %
appear before (rel.) 0.00 h
Abweichung fett
CARB-Fehler
Fehler nach Entprellung gespeichert
Fehler momentan nicht vorhanden
sporadischer Fehler
Errorcode: E3 B1 01 28 17 0B C1 BD 6C 06
-------------------------------------------------------------
228 lambda contol tolerance Bank 2 to big
Error frequency : 2
Logistic counter: 40
Engine speed 736.00 1/min
load 59.92 mg/Hub
temperature cooling water 96.75 Grad C
lambda contol tolerance Bank 2 7.81 %
appear before (rel.) 0.00 h
Abweichung fett
CARB-Fehler
Fehler nach Entprellung gespeichert
Fehler momentan nicht vorhanden
sporadischer Fehler
Errorcode: E4 B1 02 28 17 0B C1 94 6C 06
-------------------------------------------------------------
242 burning fail Cylinder 5
Error frequency : 1
Logistic counter: 40
temperature cooling water 86.25 Grad C
revolution upper limit 768.00 1/min
Airmass upper limit 87.15 mg/Hub
Airmass under limit 70.81 mg/Hub
appear before (rel.) 0.00 h
Verbrennungsaussetzer CARB B1, emissionsverschlechternd
CARB-Fehler
Fehler nach Entprellung gespeichert
Fehler momentan nicht vorhanden
sporadischer Fehler
Errorcode: F2 B2 01 28 B3 18 10 0D 6C 06
-------------------------------------------------------------
243 burning fail Cylinder 6
Error frequency : 1
Logistic counter: 40
temperature cooling water 86.25 Grad C
revolution upper limit 768.00 1/min
Airmass upper limit 87.15 mg/Hub
Airmass under limit 70.81 mg/Hub
appear before (rel.) 0.00 h
Verbrennungsaussetzer CARB B1, emissionsverschlechternd
CARB-Fehler
Fehler nach Entprellung gespeichert
Fehler momentan nicht vorhanden
sporadischer Fehler
Errorcode: F3 B2 01 28 B3 18 10 0D 6C 06
-------------------------------------------------------------
241 burning fail Cylinder 4
Error frequency : 1
Logistic counter: 40
temperature cooling water 86.25 Grad C
revolution upper limit 768.00 1/min
Airmass upper limit 87.15 mg/Hub
Airmass under limit 70.81 mg/Hub
appear before (rel.) 0.00 h
Verbrennungsaussetzer CARB B1, emissionsverschlechternd
CARB-Fehler
Fehler nach Entprellung gespeichert
Fehler momentan nicht vorhanden
sporadischer Fehler
Errorcode: F1 B2 01 28 B3 18 10 0D 6C 06
-------------------------------------------------------------
203 lambda control Bank 2 control block
Error frequency : 1
Logistic counter: 40
Engine speed 704.00 1/min
temperature cooling water 96.00 Grad C
load 54.47 mg/Hub
lambda probe voltage control probe Bank 0.14 V
appear before (rel.) 0.00 h
Abweichung fett
CARB-Fehler
Fehler nach Entprellung gespeichert
Fehler momentan vorhanden
statischer Fehler
Errorcode: CB 71 01 28 16 C0 0A 1D 6C 06

================================================== ===========

Especially when i dont drive (engine started) these errors come up in like 2 min also my MML lights up.

I disconnected my maf and sit in the car (engine running) for like 3/4 min. and it looks like my engine is running smoother then before. INPA didnt catch any errors like above.

INPA pictures

1
http://www.mijnalbum.nl/Foto-MTRHVXGO.jpg

2
http://www.mijnalbum.nl/Foto-BZLJCZUH.jpg

I just want to make sure before I spend 300 euros on a maf that it is the cause. And of above errors can be the cause of a faulty maf. Is it a good idea to drive around with no maf connected and look every day if om getting errors with inpa?

I find it also strange that cilinder 6 is doing more work then the others inpa picture 2 any ideas?

Thanks in advance
 

·
Registered
Joined
·
2,448 Posts
First of all im not a technician. I have some problems on my bmw e46 ci 1999. I recently clean my maf with breake cleaner. These errors am i getting especially when i dont drive (engine is running but car is idle) Dont know how you say it in correct english im from Holland.
Bad idea.

You should be using MAF cleaner.

 

·
Registered
Joined
·
2,448 Posts
I disconnected my maf and sit in the car (engine running) for like 3/4 min. and it looks like my engine is running smoother then before. INPA didnt catch any errors like above.

I just want to make sure before I spend 300 euros on a maf that it is the cause. And of above errors can be the cause of a faulty maf. Is it a good idea to drive around with no maf connected and look every day if om getting errors with inpa?
Your MAF is bad if it runs smooth when disconnected. You may have ruined the sensor with brake cleaner.

You might be able to save money if you buy the Hyundai MAF. It's like $150 new and may fit your model year. The newer e46 MAFs are $300ish.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Ok I will check that out! You think its a good idea to drive around for a week without maf and look every day in inpa for errors to be sure?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
Thx read the thread. Im going to try it for a couple days see if it runs better and if the errors are gone.
 

·
Registered
Joined
·
2,899 Posts
You could damage the engine running without a MAF IF your o2 sensors are shot aswell.

Thought they seem to be throwing a rich code (meaning the engine gets more fuel than it should)
Causes of this CAN be a MAF , but most likely a intake leak between the head and the MAF.

Get a can of engine starter , spray around the intake tract and listen if the engine is affected , if it is you have a leak.
If not proceed with unplugging the MAF and testdriving, if problem persists you should go for a pair of new o2 sensors(if the car runs rich for extended periods of time they will be damaged, otherwise i believe they have about 250k km lifespan)
 

·
Registered
Joined
·
5,018 Posts
You have a lean conditon thats causing a midfire find the vaccum leak. Maf cleaner is nothing but a myth I have never seen a car fixed with this snake oil
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10 (Edited)
You could damage the engine running without a MAF Get a can of engine starter , spray around the intake tract and listen if the engine is affected , if it is you have a leak.
If not proceed with unplugging the MAF and testdriving, if problem persists you should go for a pair of new o2 sensors(if the car runs rich for extended periods of time they will be damaged, otherwise i believe they have about 250k km lifespan)
You have a lean conditon thats causing a midfire find the vaccum leak. Maf cleaner is nothing but a myth I have never seen a car fixed with this snake oil


Will do to test for vaccum leak thx! Drove couple miles tonight with maf disconnected and it felt faster, especially in the lower rpm's. When I came home tonight I sat in the car for like 2 min with engine on. The car was quiet nothing strange happened. I will plug inpa in tommorow see if ive got new errors. Spark plugs wil be changed this week.
 

·
Registered
Joined
·
2,448 Posts
Will do to test for vaccum leak thx! Drove couple miles tonight with maf disconnected and it felt faster, especially in the lower rpm's. When I came home tonight I sat in the car for like 2 min with engine on. The car was quiet nothing strange happened. I will plug inpa in tommorow see if ive got new errors. Spark plugs wil be changed this week.
Be sure to get the OEM NGK platinums (4 prong). No anti-seize needed and torque is 30 Nm dry.
 

·
Registered
Joined
·
332 Posts
Thx read the thread. Im going to try it for a couple days see if it runs better and if the errors are gone.
To actually clean errors from the ecu, I think you should disconnect the battery. You can expect increased fuel consumption with the maf disconnected. And don't use break fluid on maf :) You didn't specify, but I guess problems started after you did that.
 

·
Registered
Joined
·
2,448 Posts
correct. Disconnecting the battery does not erase codes.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #17 (Edited)
Thx orientblau I have the same maf! It's the same and a lot cheaper. Going to hyundai dealer for more info. Yesterday connected laptop, still no errors......
 

·
Registered
Joined
·
9 Posts
Discussion Starter #18
Today i went to two local hyundai dealers. I asked them what a maf cost for hyundai sonata 2.5 99. One said 572 euro the other 600.... I placed my order at www.fourgreen.com 127 euro inc shipping thx for the information!!!
 

·
Registered
Joined
·
2,448 Posts
Glad you were able to save some money! :thumbup:
 

·
Registered
Joined
·
477 Posts
You have a lean conditon thats causing a midfire find the vaccum leak. Maf cleaner is nothing but a myth I have never seen a car fixed with this snake oil
if you have an oiled filter it cleans the gunk off the maf...ive done it the old way with a qtip and alcohol and the qtip is dirty after the cleaning
 
1 - 20 of 22 Posts
Top