BMW E46 Fanatics Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1 (Edited)
My SES light came on today, I had the code read at AutoZone (props to them!) and it came back as a P0036.. Definition: Heated oxygen sensor - bank 1 sensor 2 (H02S12) - Heater control circuit. Explanation: Open or short circuit condition. Probable cause: 1. Poor electrical connection 2. Failed H02S12 (Bank 1 Sensor 2)

Any suggestions? Do I wait and see if it goes away on it's own?

Thanks!!!

More details.. this is a 2003 e46 with 102,000 miles. It was 90 degrees out today when it went on, but I had just turned the car on.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #2
I did find this handy diagram.. I may try to find this under the car tonight: <br> <img src=http://img109.mytextgraphics.com/photolava/2008/03/12/179a-49t20u54p.png>
 

·
Registered
Joined
·
19 Posts
I had the same problem, just changed both post-cat sensors. They're quite tricky to access, special lambda tools will make things easier:

 

·
Registered
Joined
·
72 Posts
Discussion Starter #6
How much is that in usd? I would do the conversion, but I am not familiar with that sign.
 

·
Registered
Joined
·
19 Posts
Oh **** I was talking in euros! I can't understand what happenned...

100 euros both... that's around $130

OEM quality but not from BMW stealership. Bosch or NGK I don't remember. They look exactly the same as the originals.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #10
Intense: are you sure? From the diagram it looks like it would be the one to the left in the picture above (next to the silvery one). I am about to attempt this. I should probably just do both, eh?

Thanks for your help - it is greatly appreciated!
 

·
Registered
Joined
·
4 Posts
did you check if you got 13.6v or more from your alternator?
this code p0036 did show up for my BMW, and my alternator was getting :thumbdwn:
i replace the voltage regulator for $39, and the code never show up again.
 

·
Registered
Joined
·
957 Posts
Just got this error code. I knew it was the shop that installed my tse3. They blowtorched the bolts to loosen them and prob burned or broke the sensor wires. Of course when I took it to them they said it wasn't their fault. The light came on a block after leaving their shop. ****ers.
 
1 - 12 of 12 Posts
Top