BMW E46 Fanatics Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
617 Posts
Discussion Starter #1
Upon start up this morning my engine was squealing. It went on till after like 20min of driving. Then after it never came back. Once the car cooled off and I started it again, its back.
Engine belt?
Tensioner?
Idle pulley?

Going to go spray some wd40 on the belts tomorrow morning to try to pint point problem.

Any ideas? and where i can get the parts for cheap
 

·
Registered
Joined
·
1,443 Posts
idler tensioner it happened to me and its just gonna keep getting worse
 

·
Registered
Joined
·
743 Posts
Upon start up this morning my engine was squealing. It went on till after like 20min of driving. Then after it never came back. Once the car cooled off and I started it again, its back.
Engine belt?
Tensioner?
Idle pulley?

Going to go spray some wd40 on the belts tomorrow morning to try to pint point problem.

Any ideas? and where i can get the parts for cheap
NEVER spray WD-40 or any other lubricrant on the belts!!!!
Like someone said you can spray the backside of the pulley (where the bearings are) being careful not to get any on the belt, or the surface of the pulley.

My vote is tensioner and/or idler puller. On both of my cars this has happened. Both pulleys combined are ~50.00 from rmeuropean.com
 

·
Vendor
Joined
·
13,153 Posts
Upon start up this morning my engine was squealing. It went on till after like 20min of driving. Then after it never came back. Once the car cooled off and I started it again, its back.
Engine belt?
Tensioner?
Idle pulley?

Going to go spray some wd40 on the belts tomorrow morning to try to pint point problem.

Any ideas? and where i can get the parts for cheap
Chances are as mentioned above its your belt tensioner. We have replacements available below...

Click HERE for more information.


Please let us know if you have any questions! Feel free to shoot me a PM or email.

Best,
Joe
 

·
Registered
Joined
·
86 Posts
I Had the engine cricket noise...replaced the full tensioner pulley.46$ from advance auto and they even had it in stock!!!:excited:.after i did it ,it wasnt all gone.the noise was still there but really low and only when i rev it..after 2-3 weeks it seems to have gone..rarely i can hear it..but meh no big deal..much better than before:p
 

·
Registered
Joined
·
6 Posts
Very likley to be Adjusting pulley{surpetine belt),Deflection pulley{if equipt),Or the A/C adjusting pulley.It's a good idea to replace all three pulleys and install new belts.I just did this to my 325i wagon and there is no more high picted noise.Cost under 150 dollars for the parts from Pelican parts.com. and only took 90 mins. to do the work.Note:a/c pulley was machanical and my adjusting pulley hydralic.a/c tensioner will move after you remove the upper mounting bolt and the pulley on the hydralic tensioner moves via 8mm hex head.Also be sure to identify the type of adjusting tensioner you have before ordering,as these cars came both.good luck..............
 

·
Registered
Joined
·
384 Posts
I'm going to take my belts off, which looks like involves removing air intake and fan...

and give the pulleys a spin, hopefully pinpoint the noise.
 

·
Registered
Joined
·
2,027 Posts
yupp...Had that noise and just had all that replaced @ IMPRESSIVE AUTO a few weeks ago...out with the old components and in with the new...belts and all...

 

·
Registered
Joined
·
167 Posts
Yeah I think need to change my belts too. My engine wines like its supercharged when the A/C is on lol.

Sent from my DROIDX using BimmerApp
 
1 - 20 of 27 Posts
Top