E46 Fanatics Forum banner
1 - 20 of 25 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Noob here
Recently brought my first project car an 03 325i Manual. Noticed when putting the car in reverse the car instantly shuts off. After two attempts of putting it in reverse the car will crank but not start. The previous owner mentioned that the DME, EWS, and key ignition was swapped. It wasnt professionally done correctly because when scanned it prompts a different VIN number. The car runs and all other gears work. I have a video demonstrating the issue on YT. I was just curious if anyone has experienced this issue before. I know this is a long shot but Im in the JOCO area in NC. I also have codes Ive scanned from BMW scanner tool. Thanks

 

Attachments

·
Registered
Joined
·
133 Posts
Ok, so I believe you have few issues here.
1) Because of the issues mentioned above you need to realign EWS and DME. You can do this in BMW Scanner. Look at forum and YouTube.
2) DME and ABS error codes shows that you are out of time. Seems to be your timing chain is kaput which causes the engine to die. But you also have error codes for VANOS which might be actually the case and not the timing. But all points to this unfortunately.

P.S. going through your codes again I would realign the EWS and DME and double check that all modules have the same mileages and vin and clear the codes and will see again what it shows. Some of the error codes might be caused by that instead. Some of them might be old as well.
 

·
Registered
Joined
·
9,607 Posts
P.S. going through your codes again I would realign the EWS and DME and double check that all modules have the same mileages and vin and clear the codes and will see again what it shows. Some of the error codes might be caused by that instead. Some of them might be old as well.
If DME and EWS having password alignment issue then why engine is able to run as in video?
 

·
Registered
Joined
·
9,607 Posts
Noticed when putting the car in reverse the car instantly shuts off. After two attempts of putting it in reverse the car will crank but not start.
Does this car have auto to manual tranny conversion or stock manual? You can find out by enter the last 7 digits at RealOEM website.
So as soon as it was shifted to reverse then it died and clutch pedal still down to floor (clutch disengaged)?
 

·
Registered
BMW E46 Saloon Msport 320i 2004 Manual
Joined
·
63 Posts
If DME and EWS having password alignment issue then why engine is able to run as in video?
Im with @Sapote on this, the engine is running so there is no EWS issue, it would stop the car from running.
Looking back at the video there is COG on the painel while the car is manual, either this had the cluster swapped or it was a auto -> manual swap as mentioned by others in here.
Check real oem as suggested and report back what it says about your transmission.
 

·
Registered
Joined
·
133 Posts
If DME and EWS having password alignment issue then why engine is able to run as in video?
Rolling code issue is not consistent. It comes and goes without a notice. I did t watch a video, but according to the description of the issue, including sudden and frequent engine stops - it points to that direction. Once again - I didn’t watch video, only refering to description and error codes.
 

·
Administrator
Joined
·
19,712 Posts
That car is a mess.
  • Auto->MT swap and did not code the car properly
  • Swapped in donor DME/EWS/keys/locks, which means you can never buy new BMW keys, VIN mismatch with ABS/cluster/LCM
  • MT swap wiring was likely done incorrectly/incomplete, likely related to the engine cut off in reverse
  • More problems yet to be discovered
Edit: after looking at the screen shots, I think the BST (battery safety terminal) is causing the engine cut off and no start. Inpect the positive battery cable for looseness at the BST.
 

·
Registered
Joined
·
9,607 Posts
Edit: after looking at the screen shots, I think the BST (battery safety terminal) is causing the engine cut off and no start. Inpect the positive battery cable for looseness at the BST.
Bali, I saw the code but if BST was bad enough then starter couldn’t crank, but it cranked strong.
 

·
Registered
Joined
·
9,607 Posts
Rolling code issue is not consistent. It comes and goes without a notice. I did t watch a video, but according to the description of the issue, including sudden and frequent engine stops - it points to that direction. Once again - I didn’t watch video, only refering to description and error codes.
No need to see video, as the description says car ran fine in all forward gears, hence no EWS to DME issue.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #15 ·
Does this car have auto to manual tranny conversion or stock manual? You can find out by enter the last 7 digits at RealOEM website.
So as soon as it was shifted to reverse then it died and clutch pedal still down to floor (clutch disengaged)?
stock manual and yes clutch pedal is still down to floor
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #16 ·
That car is a mess.
  • Auto->MT swap and did not code the car properly
  • Swapped in donor DME/EWS/keys/locks, which means you can never buy new BMW keys, VIN mismatch with ABS/cluster/LCM
  • MT swap wiring was likely done incorrectly/incomplete, likely related to the engine cut off in reverse
  • More problems yet to be discovered
Edit: after looking at the screen shots, I think the BST (battery safety terminal) is causing the engine cut off and no start. Inspect the positive battery cable for looseness at the BST.
Yes indeed it is a mess
No MT swap was done just the DME/EWS/key ignition was swapped
ill check the positive battery cable thanks
 

·
Registered
Joined
·
9,607 Posts
Might be intermittant?
This will take some electronic troubleshooting.
The DME reported that a little too much voltage drop across the BST (it compared the voltage on the branches before and after the BST). I know the DME has signal from the branch before BST but I didn't know it also has signal connected to the big red cable (to the jump post - starter - alternator) and where is this connection. It makes sense that the DME should have these signals, but I haven't seen the wiring.
 
1 - 20 of 25 Posts
Top