E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter · #1 · (Edited)
Hi Guys,

I came across an issue two nights ago. I was out at the time, but when i went to leave, the car had a weird rattling noise when i started it up. It was a little cold that night (23 degrees, compared to the usual temp of 32 here), so i waited for the car to reach normal temp but the noise didn't go away. Ever since, the car has been sitting in the garage. I've tried to start it and let it idle till operating temp a few times but the noise seems to stay. here's a video of the sound, hopefully you guys could help me out

It's a 2003 e46 325i, automatic.

Engine Rattle:
http://youtu.be/iKoOapDISTY

I also came across a leak under my engine here's another video to show you guys. Not sure where it's coming from, and was hoping maybe it's a common leak?

http://youtu.be/qma6v3NmXG0

I bought the car at 89,000kms and it's now on 130,000km. I've changed the valve/rocker cover gasket, spark plugs, oil, oil filter, cabin & air filter at 100,000kms. Though, I haven't changed my vanos seals yet.

I've removed the air intake to take a better look but i haven't been able to see or feel anything loose. i know it can't be my belts or fan as i inspected that only recently when I replaced my power steering pump.

If you guys could help i'd be much appreciated!
I've searched around but there's various of answers to the rattling.. and i wanted to be sure what it could be before i started replacing things since i don't have much time to spare these next few weeks.

I'm not sure it'll help with diagnosing the car, but it seems to idle a little rough on some nights and the rpms drop to 500, and the car vibrates a lot. In one or two instances I've accelerated slowly to take off and the car stalled..

Thanks in advance
 

·
Registered
Joined
·
687 Posts
"it was a little cold that night" --- says it was 73 degrees. quick, switch to a lighter weight oil!

seriously though...you already replaced the headgasket? there was no engine damage for whatever necessitated that?

for rattle...i would always check the DISA first. remove and inspect flap, test for vacuum with the finger test, and check the o-ring. if not the DISA, i would move on to the vanos. This is of course assuming you've scanned the car already and not pulled up any codes.
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #4 · (Edited)
Engine Rattle & Oil Leak? Help please!

This is a good thread on common oil leaks. It includes pictures.



http://forum.e46fanatics.com/showthread.php?t=882732&referrerid=154826



Your videos are private.

Thanks for the link! Its extremely useful, and i think i might have found the leak issue from the thread already; i think it could be the oil filter housing gasket or the power steering hoses and over time accumulated underneath..

Thanks for the heads up, links are fixed


"it was a little cold that night" --- says it was 73 degrees. quick, switch to a lighter weight oil!

seriously though...you already replaced the headgasket? there was no engine damage for whatever necessitated that?

for rattle...i would always check the DISA first. remove and inspect flap, test for vacuum with the finger test, and check the o-ring. if not the DISA, i would move on to the vanos. This is of course assuming you've scanned the car already and not pulled up any codes.

Sorry, i must correct myself it was the valve/rocker cover gasket i meant, not the head gasket, my mistake.

Thanks; Will check DISA in the morning and will report back. I haven't scanned for codes yet; as my cousin is out of town with code scanner. The links for the videos is fixed, hopefully it could give you more of an idea what it could be?
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #5 ·
I checked out the DISA today and it seemed fine, although there was a little play before the spring action happens; should i be replacing it soon? or is it suppose to have some play?

here's a video when i checked the DISA

http://youtu.be/W8SB9WMzsJ8

I looked around for places for the leak whilst I had a better view with a lot of the parts out; I'm sure it's the Vanos Oil Line, so I'm going to replace that too once I've found out the rattle noise issue.

I've listened around and figured that I'm going to replace the Vanos Seals. The sound seems to be around that area or underneath the engine but i'm going to scan the car for codes as soon as i get the scanner.

Is there anything anyone else would recommend that could be the problem?
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #6 ·
So, i was sussing out the sound more and more lately and have been searching around non stop. I am now suspecting it might be my water pump or my alternator? I've done the dash test, and my battery was on 12.8 with engine off, and alternator went to 14.1. Would the alternator make this sound even if it's working okay? or could it mean it is going to fail soon?

here's another video from the front; I realised it is a lot louder from where the Aux fan is. Any help would be great?

http://youtu.be/khAa0l5pB9k

I'm scanning for codes when my scanner arrives (today or tomorrow). Will keep this thread updated for anyone else with similar problems..
 
1 - 6 of 6 Posts
Top