BMW E46 Fanatics Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter #1
Hi.
This is the first time I install my own sound system. The only problem that I have is that there seems to be an engine noise (really loud ones). I’ve install clarion 935vd for the head unit, I put the head unit in the underneath the back seat. From the head unit I take two sets of RCA cables. One to the first two way phoenixgold crossover (MX2), then go to 2 chan amp BRAX X1000, where it’s connected to 10” W7. The other RCA goes from the head unit to the second two way phoenixgold crossover (MX2) (I’ve got two of the same phoenixgold crossover).
From the second crossover I took 2 sets of RCA, both of the go to 4 chan Xtant amp (4180c), I’ve used it before in my previous car and it worked fine. From the Xtant, it goes to 2 6.5” scanspeak speaker in the front, another 2 go to 5” scanspeak tweeter in the front. I have no amp for the back speaker, only from the head unit. My car is 323i 2000 BMW. For the amp ground I take from the factory ground in the right behind of back seat (8 GA). For the crossover and head unit ground I took from left factory ground behind back seat. For the power I take directly from the battery in the trunk (8GA). I run the RCA separately from other wire, RCA on the left of the car and other wire in the right of the car.
I went to a few audio stores, one of them did a check on it and told me that the noise is coming from the Xtant amp. So I bought a used 4 chan Butler tube amp (TD 475). Then I installed it, but the engine noise is still there. I went back to the store and they only change the butler amp with the same cable to four channel Alpine amp. and the engine noise was 80% gone. Then the guy tried to bypass my crossover and the engine noise is 100% gone.
So do you guys have any suggestion to what I’m supposed to do to eliminate the engine noise? Thank’s for your help.
 

·
Registered
Joined
·
98 Posts
Discussion Starter #3
i used Rockford RCA ( Rf matrix ), i also try other RCA but there are no different.
 

·
Banned
Joined
·
1,344 Posts
how hard was it to install your headunit? i dont know much about the electronics. how hard on a scale of 1-10
 

·
Registered
Joined
·
179 Posts
ground

I was getitng alternator whine, so i decided to ground to the same point as factory. Used a veryinsulated zero noise cable, and gold plated connectore. No more noise, seems to have done the trick. good luck.
 
1 - 8 of 8 Posts
Top