E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I changed the valve cover gasket the other day on my 325i. I broke a vacuum line which was very brittle so I replace that, and still the engine light is on..... had a guy at Oreily's check the code and it was a air injection related. The vacuum line I replaced was on the secondary air check valve.

Any thoughts. Recommendations on what to do for a fix. The leak sounds like its coming from right in front of the cabin air filter tray. ???

All input is appreciated. Thank you.
 

·
Registered
Joined
·
204 Posts
There are a few hoses, did you replace the vac hose that runs next to the fire wall too? You might wanna do that
Look at the oem diagram might clear up your question
If you search 11727553063 on realoem.com- that's the valve and it'll bring up the diagram and part numbers for the whole system
 

Attachments

·
Registered
Joined
·
16 Posts
Discussion Starter · #4 ·
There are a few hoses, did you replace the vac hose that runs next to the fire wall too? You might wanna do that
Look at the oem diagram might clear up your question
If you search 11727553063 on realoem.com- that's the valve and it'll bring up the diagram and part numbers for the whole system
I replaced the one that runs along side the passenger side of the motor. I'll take a look at the back one tomorrow when I get some time and replace it if it is broke or not since everyone I have found so far was brittle.

The guy at Oreily's reset the code. It has not popped back on yet. Would this hint at problem solved or will it not come back on since it was reset?

Thank you.
 
1 - 4 of 4 Posts
Top