E46 Fanatics Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Haven't been able to find a fix to this and no one has gone into my specific detail.
First off, EML limp mode is going like this:
EML Traction and the amber brake light comes on like if you turn off traction all the way off
Throttle input is zero
Severely rough idle of 1k to 1.4k rpms even when stopped and pulled over

All this turns off with a simple turn key on off and goes away.

I first tripped this type of deal drifting my car around in the wet with no traction control on while pegged at redline on one of my drifts car goes into limp mode with EML lights on.

I haven't been drifting lately to avoid this issue but now I am getting it to turn into this limp mode in a specific manner of 60mph to 80mph pulls in 5th gear, only when gas is fully pressed. I've also ran into the limp mode trying to pass cars in third gear up hills in the wet, I feel a little traction loss for a split second then limp mode. I replaced my faulty o2 sensor that only showed codes through a computer (no PO----) and then this limp mode went away but then I did another slide today, tried to get onto a highway in 4th gear at slightly over 100mph and limp mode. Knowing how I tripped limp mode before, I did the 5th gear 60-80 pull and got the same issue. Very confused because I don't get a check engine light or codes for this.

I do not know if I can get a definitive answer for what part to replace but maybe some way to read this fault, I could possibly get my friend with some BMW software to read this when the fault occurs but otherwise I am lost right now.

(I am a the pinnacle of BMW asshole but information is necessary for diagnosis)
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
Absolutely forgot to mention
Year: 2004
Model: 325i 5 speed manual, however somewhere in the history of this car the original m56 motor, the SULEV, and automatic transmission was swapped out and everything coded.
Miles: Approaching 169k miles

any other information I will reply as fast as possible so I can get my car back to get back to destroying it, fully aware I am not being nice to this car.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Don't see the point of you replying unless just to complain, in all reality I actually am not destroying the car and probably do not intend to if I am trying to fix it. Thanks for the great comments tho
 

·
Administrator
Joined
·
19,135 Posts
You need to be able to read and clear BMW-specific trouble codes from all control modules, such as the DME and ABS modules in your case, to troubleshoot this. Guaranteed you currently have ABS fault codes for clues here.

First guess is that the ABS module is attempting to signal the DME to control throttle and that is failing, hence why you get the EML (throttle control), ABS and Brake lights on.

First thing I would do is get setup with BMW Scanner 1.4. You'll need a cheap Windows laptop, the BMW Scanner 1.4 cable and the software.
https://www.xcar360.com/bmw-scanner-1-4-0-car-diagnostic-interface-tool-code-reader.html
See links in this thread for more info.
https://forum.e46fanatics.com/showthread.php?t=1130405

If you really want to dive deeper, you'd get a K+DCAN cable and setup the INPA software, which is part of the BMW Standard Tools suite.
https://drive.google.com/file/d/1DzNLnAgB4bz1IkJDpAM5BSuRhckgnLiQ/view?usp=drivesdk
https://forum.e46fanatics.com/showthread.php?t=1227470
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
Soft code popped up, P16A7 which is pointing to a bad cat or maybe the MAF, but most likely the cat so it is up for debate if I am gonna go through and do some catless headers, take out the OE headers and take out the Cat material, or just sell the car and let the next person deal with it.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top