BMW E46 Fanatics Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
First post here because usually any issue I've ever had with my e46 330i has been identified and resolved using past comments!

Anyways, I recently bought a e46 M3 (May 1, 2003) because my 330i (October 2001) has been so good to me. After running Ista+ 4.07 on it, I found a bevy of weird "No communication possible with" codes that are suspiciously identical to my 330i's codes when I ran those. Moreover, when Ista+ is connected running a system check on the CAN bus, I once got the message that the Basic Module has been disconnected (on the M3).

Both cars run flawlessly with no electrical issues (save for a yaw sensor that doesn't work on the e46 ***8211; but I always disable DSC to solve that).

The K+DCAN cable I'm using has seventh and eighth leads bridged, and it reads in INPA when I had that installed (I don't any longer). It is also able to access the DME in the 330i through Ista+ and run the Vanos check, so I know that it's at least doing something.

Even weirder, OBD Fusion with an Elm wi-fi connector doesn't seem to want to read any live data from the sensors (O2, lambda, etc.) on the M3 but does on the 330i. On both cars, no codes are showing up, which I find suspicious because the brake-wear indicator is tripped as is the battery-safety terminal on the 330i resulting in an airbag light.

When I tried to clear the internal codes through ISTA+ on the M3, the Control Unit Tree showed a number of the individual units turning red. After about five or so went red, it wanted me to turn off the ignition for a "Manual Terminal" reset. I did so and the message just stayed on there for two minutes before I canceled out of frustration.

I've went ahead and posted the error reports from the 330i and the M3, as well as the Control Unit Tree from the M3.

I'd appreciate any advice you have on getting those codes cleared, accessing the live sensor data and figuring out whether I maybe fried something in the computer or installed Ista+ incorrectly.
 

Attachments

1 - 1 of 1 Posts
Top