BMW E46 Fanatics Forum banner

1 - 15 of 15 Posts

·
Registered
2003 E46 325i
Joined
·
15 Posts
Discussion Starter #1 (Edited)
Hello,

As stated in the title, my traction control light and brake light (yellow) is permanently on after I installed an Android head unit with a reverse camera, with a can bus for steering wheel button control for the player as well.

Is it safe to assume that this issue is entirely caused by the can bus installed for these stuff? Or could it be the steering angle sensor because I've connected the media controls for an aftermarket player to the M-Sport steering wheel?

Any other possibilities or solutions? Thanks.
 

·
Here to serve y’all
2004 330Ci 85k miles
Joined
·
13,204 Posts
Which year and model E46 is this? You didn’t mention that and I don’t see it in your user info.

Read the ABS/DSC module trouble codes to see why those dash lights are on.
 

·
Registered
2003 E46 325i
Joined
·
15 Posts
Discussion Starter #3
Which year and model E46 is this? You didn’t mention that and I don’t see it in your user info.

Read the ABS/DSC module trouble codes to see why those dash lights are on.
Oops sorry. 2003 325i.

Will get it scanned tomorrow. I highly suspect the can bus as the only cause as there was no such issue occurring before the installation of these stuff. But would be great to get feedback from others who may have experienced this.
 

·
Registered
'03 325iT Mystic Blau
Joined
·
2,974 Posts
Mine freaks out over the steering angle sensor all the time. It's gotten to the point that before I even break out the BMW Scanner cable I just do the calibration routine of turning lock to lock a couple of times, and it goes out.
 

·
Registered
2003 E46 325i
Joined
·
15 Posts
Discussion Starter #5
Mine freaks out over the steering angle sensor all the time. It's gotten to the point that before I even break out the BMW Scanner cable I just do the calibration routine of turning lock to lock a couple of times, and it goes out.
Do you have an aftermarket head unit / steering wheel media controls / reverse camera installed as well which is causing issues to the steering angle sensor? Or is the steering angle sensor issue caused by a different reason?
 

·
Registered
'03 325iT Mystic Blau
Joined
·
2,974 Posts
Do you have an aftermarket head unit / steering wheel media controls / reverse camera installed as well which is causing issues to the steering angle sensor? Or is the steering angle sensor issue caused by a different reason?
Who knows what causes it, but I have a Dynavin N6 with a backup camera, but stock steering wheel controls.

That thing can get confused by having new tires mounted or all kinds of other reasons.
 

·
Registered
2003 E46 325i
Joined
·
15 Posts
Discussion Starter #7
Who knows what causes it, but I have a Dynavin N6 with a backup camera, but stock steering wheel controls.

That thing can get confused by having new tires mounted or all kinds of other reasons.
Thanks for sharing. Is your stock steering wheel controls connected to your Dynavin?
 

·
Registered
'03 325iT Mystic Blau
Joined
·
2,974 Posts
Hmm alright, I'll try to scan the codes first to confirm the issues. Will try to disconnect the steering wheel media controls and see if that solves the problem or not.
Just scan the codes and see what's up before you start planning on tearing into your car. Like I said, it could just need the calibration sequence done to make it happy.
 

·
Registered
Joined
·
117 Posts
It's absolutely the canbus. I have the Eonon head unit in mine and if the canbus is installed, it throws the lights, disables all dashboard lights, and doesn't let me roll down my windows. Works fine without canbus, just no steering wheel controls.
 

·
Registered
2005 BMW 330i
Joined
·
231 Posts
Did you have to unplug the dsc switches by chance?
 

·
Registered
2003 E46 325i
Joined
·
15 Posts
Discussion Starter #14
Got it scanned and it says it's the pressure sensor. The mechanic believes it's the DSC pressure sensors. According to him, our Android head unit, can bus, reverse cameras, etc, shouldn't affect the DSC or brake lights because they are plug-and-play which doesn't require modifications to the wiring.
 

·
Registered
2003 E46 325i
Joined
·
15 Posts
Discussion Starter #15
I have not changed the pressure sensors yet, but without the can bus, the lights have been gone and never showed up again. I'm gonna try to install the can bus again for my steering wheel controls and reverse cameras, and if the lights pop up again, I'll change the DSC pressure sensors to see if it fixes the issue. If it doesn't, I'll scan for codes/errors again. If all else fails, I'll just remove the can bus permanently.
 
1 - 15 of 15 Posts
Top