E46 Fanatics Forum banner
1 - 20 of 45 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Dear E46 Fanatics
I don’t know if it is the right place to add my topic since Iam new member.
Can anyone help a mechanic in emergency situation.
I have no heat from my vents, I have done all this.
1. Change my cooling valve
2. Change thermostat
3. Flushed my heater core
4. Change cabine sensor behind radio
5. Bleed my cooling water from any air
But I still got NO heat from my vent!
Can anybody any good soul help me what the problem is. Please Please Please
From
Bmw4ever786
 

·
Super Moderator
2004 325i automagic
Joined
·
3,858 Posts
Blockage in the pipes leading to or from the heater core?

Edit: There may be flow issues as well. Check out post 43 in this other no heat thread:

Edit 2: Not sure I understand what post 43 below is saying exactly, so take with grain of salt disregard.

 

·
Registered
Joined
·
9,012 Posts
I have no heat from my vents, I have done all this.
1. Change my cooling valve
2. Change thermostat
3. Flushed my heater core
4. Change cabine sensor behind radio
5. Bleed my cooling water from any air
But I still got NO heat from my vent!
So only 2 things can cause this problem:
1) no hot coolant
2) there is hot coolant but no flow.

To make sure there is coolant flow, disconnect the cable from the heater valve (you called it cooling valve) and this should open the valve all the time.
 

·
Premium Member
E30M3 Race F10 535 R1150Rt M Coupe
Joined
·
11,286 Posts
I'd be looking at the values of temperatures of left/right heater cores and stepper motor positions.

I'd look even harder at the stratification numbers. That layer wheel could be bad or the IHKA could be wonky.
 

·
Registered
2016 340i xD 6-spd
Joined
·
26,645 Posts
Nothing personal, OP, but 95% of the time, no heat does mean air in the system.

I've been here years...and it's almost always true that the OP said he bled the system--two, three, five times--no heat still is usually a bleeding issue.

Don't totally dismiss that before spending money on more parts or time elsewhere. Just saying...nothing personal!
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #18 ·
Using defrosters... does heat come out when you do that ?
Follow the cable that is connected to 3 dot temperature wheel. There is a plastic assembly that pops out that needs to be put back in.
Thanks maybe this is the problem
I’ll check it tomorrow
So only 2 things can cause this problem:
1) no hot coolant
2) there is hot coolant but no flow.

To make sure there is coolant flow, disconnect the cable from the heater valve (you called it cooling valve) and this should open the valve all the time.
Hi
I also have tried to disconnect cable from heater valve but no luck!!!! I suppose that it could be my vent assembly that need to pop back from joint plastic.
 
1 - 20 of 45 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top