E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I had some issues with the Key going into the Ignition cylinder, which has been solved now (thanks guys for responding on that Thread: http://forum.e46fanatics.com/showthread.php?p=14134701#post14134701)

Now, i was finally able to start her up with a Jump Start. I ran it locally for a good 10 - 15 minutes. Then, shut her off and tried to Start her up again and no dice..All Instruments come on in the cluster, no Crank no Start :banghead:. So, far i got a New battery, thought it was the Starter, but it cranked right away :clap: when i got it jumped. Checked for Voltage on the battery terminals in while she was on to rule out the Alternator. Not, sure what could cause this issue. Any ideas guys?


Thanks,
 

·
Registered
2005 330xi Auto, 2006 330ci Vert Auto
Joined
·
348 Posts
So, far i got a New battery, thought it was the Starter, but it cranked right away :clap: when i got it jumped.
Please clarify what you're saying here. Not sure I understand your sentence. Did you or did you not get a new battery? If you did get a new battery, why would you need a jump?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
Please clarify what you're saying here. Not sure I understand your sentence. Did you or did you not get a new battery? If you did get a new battery, why would you need a jump?
Kaboom28 - Yes, i got a new battery but it was not Cranking or doing anything.. Guess it got weaker from all the Lights and the Heater coming on every time i tried to start her up.

FYI, i was also cleaning out the Water that was in my Fuse box in the Glove Box location (Hurricane Irene, the car has been sitting for like 4 months). I even Found Water on the Wires in the DME box? (where the Computer is), i dried out everything. I changed out the Battery in my Diamond key and was prepping the car to get it towed to the Mechanic to get the Starter Replaced coz @ this point i was sure it was the Starter.

I just wanted to Try & start it one last time, and I heard the Starter clicking (which was not the case untill today)...Then, i decided to try a Jump start, and Right away it Turned on. Drove it around for like 10 mins, had it idiling for like 15mins. Then, i shut it off. Tried to re-start and No Crank??

Could it be something to do with my Ground wire, coming from the Battery? Can i be safe & rule out the Starter?

Help!
 

·
Registered
2005 330xi Auto, 2006 330ci Vert Auto
Joined
·
348 Posts
DesiDon:

If you have all that water in the fuse box and in the DME box, can you be sure that there's no corrosion in there that's causing you problems?

With all that water in the fuse box, first thing I would do is measure the voltage at the starter referenced to the engine block as the ground and see what you get when you try to start it. It looks to me like you're not getting 12V at the starter whereas when you're getting a jump, since you're getting ~14.4V from the alternator on the donor car, there's enough to turn the starter over. There's a good chance you have corrosion somewhere and you don't have a good ground.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
Thanks for responding Kaboom28, I pulled out the DME and cleaned all the pins...there was very little "white spots" at the bottom of one of the socket pins...I also spoke to a Service adviser and told him about wetness in the DME box...he was like well, if that DME got wet it would not Crank over at all. So that's kind of a relief. Yep, checked for Voltage i was getting around 12v at the engine bay, then i even checked for voltage down below @ the starter while turning the Ignition on.

Think i found the Issue though...I pulled out the Clutch Switch Starter Kill lock thingamajig and it was Wet and didn't push down all the way..I dried it completely and Cleaned off the corrosion. Now, it starts every 2 times i try without needing a Jump Woo Hoo!!! I ordered a Replacement Switch used from Bavarian Auto over in CA from Ebay...$13... $75 new @ the Dealer. ..The weather is going to be warm the next few days here in NY. .. hopefully it will start the first time once i replace this switch.
 
1 - 6 of 6 Posts
Top