E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello,
First off Id like to say that Im new and am not an experienced mechanic in any way, so please bear with me as I describe my problem. I would greatly appreciate any assistance that may lead to a solution.

I have a 325i 2003, The ventilation system has stopped working on my vehicle. When I turn on the fan (no AC) from the IHKA control panel the fan/motor sounds like it turns on and it is running, however no air at all comes out of the vents inside my car. I looked at other articles on internet and it sounded like my symptoms were very similiar to a faulty "BLOWER MOTOR RESISTOR". So I replaced that which was easy, however it did not fix the problem.

After replacing the "BLOWER MOTOR RESISTOR" I had the same symptoms,
1. turn the air on
2. I can hear the blower/fan, (not sure which one is which sorry) its the normal sound you hear when turning the fan control up.
3. No air comes out of my vents.
4. If I put my hand down by the control peddles (gas/break) I feel the air coming out, so its almost as if something is blocking it or?

Would anyone be able to give me some pointers on these symptoms? Again I appreciate any help that the great users of this forum could help me with.,

Thank You
Jason D.
 

·
Registered
Joined
·
379 Posts
any help please
There is a wheel between the center vents with red or blue dots on it. If you are trying to warm the car and the dots are set to blue no air comes out. Likewise, if you are trying to cool the car and the dots are on red then no air comes out. There is a better description in the manual , check it out.
 

·
Registered
Joined
·
125 Posts
Stupid question #1: What vents are selected on the left side of the IHKA?
(top, center, floor)?
Stupid question #2: Have you taken the cabin air filter cover off to make sure it isn't clogged? (located under the hood, dead center, against the firewall)
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Question 1. Ive tried all of the 3 and in combination. A slight bit of air comes out of the floor vent on driver side, however its barely noticable. All others there is no air whatsoever coming out. Just the sound of the blower/motor, not sure which device makes the wooosh sound but I can certainly hear it, I just get no air.

2. Yup I just double checked that to, nothing is cloggin the cabin air filter.

beef1020, I have moved the scroll button to both hot and cold when heat is on, I get nothing.

I have no AC nor regular air, it just doesnt blow air of any kind at all, I hear the blower/motor humming as normal however there is just no air, and I replaced the BlowerMotorResistor so that is ok, I would love to atleast fix the ventilation myself and then use that saved money to fix the AC. Its crazy money to spend.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
any guesses mechanically or electically as to why the motor/blower would be on and no air comes out?

Thanks
 

·
Registered
Joined
·
3 Posts
I'm having the same problem with my 02 325Ci, the blower responds to speed changes, but i can hear the flaps struggling to switch the air outputs. Sometimes they work after a few seconds, but increasingly... they don't. Possible lube issue or stepper motor?. Has this issue been figured out yet? I've been researching and having trouble finding a solution. Seems to be worse when its warm outside... like when I need AC on my face. When they're not working, air wont come out anywhere, even with the blower humming away on max. I try all possible combos (foot, face, windshield and/or defrost, AC on and off) with just slight air coming out in the foot well. It would be great to find a potential diagnosis before visiting my local Indy for an error scan as suggested by the link below. Thanks! (fingers crossed)

http://tech.bentleypublishers.com/thread.jspa?messageID=401016
 
1 - 7 of 7 Posts
Top