E46 Fanatics Forum banner
901 - 920 of 920 Posts

·
Registered
2003 325i MT
Joined
·
357 Posts
Thanks mate! Okay I did option but was not sure😊

Anyone knows a wireless camera is working with n7 pro. Also power output from stock Dynavin harness for camera is 12v?
The N7 Pro does not have a power out for cameras. I used a wired camera ($15 on Amazon), and pulled the power from the reverse light in the trunk lid. I got the camera style that replaces your license plate light. I did have to cut part of the plastic on the light for it to fit, and I used black RTV to seal the camera in place. The wire with the video feed that comes with the camera has a 12V+ wire, this wire also gets power from the reverse light, and is connected to the Dynavin as a signal to turn the video feed on. The Dynavin unit does not have the option to automatically turn on the video feed when an image is sent through the RCA, it needs a 12V+ signal to tell it that you have engaged reverse.
 

·
Registered
2003 325i MT
Joined
·
357 Posts
That TAKES power from the reverse camera. When the head unit GETS 12V+ via that wire, it will switch to the video feed from the camera.

I guess you could find a 12V+ source inside (if you have an automatic it may be easier). Then do the wireless stuff you planned. It may work.
 

·
Registered
Joined
·
53 Posts
Thanks friend, I got confused , because cable loom is saying reverse canera power...
That TAKES power from the reverse camera. When the head unit GETS 12V+ via that wire, it will switch to the video feed from the camera.

I guess you could find a 12V+ source inside (if you have an automatic it may be easier). Then do the wireless stuff you planned. It may work.
The instructions above are different than Dynavin's instructions, but given Dynavin's instructions aren't working I'm tempted to try JPT's instructions.

I followed Dynavin's instructions here and have the backup camera connected in the trunk to ground (on the chassis), the reverse light power (blue/yellow), and the red line is connected to the "REVERSE TRIGGER" on the Dynavin harness per those instructions.

When I go into reverse I get power to the camera (tested with a voltmeter), but the Dynavin doesn't automatically switch to camera view. I have to manually select the camera at which point everything works as expected. I want it to select the camera automatically when I'm in reverse.

Strangely, I don't have an option for "Reverse" in settings. It literally doesn't exist on my screen.

Any help is much appreciated.
 

·
Registered
2003 325i MT
Joined
·
357 Posts
The instructions above are different than Dynavin's instructions, but given Dynavin's instructions aren't working I'm tempted to try JPT's instructions.

I followed Dynavin's instructions here and have the backup camera connected in the trunk to ground (on the chassis), the reverse light power (blue/yellow), and the red line is connected to the "REVERSE TRIGGER" on the Dynavin harness per those instructions.

When I go into reverse I get power to the camera (tested with a voltmeter), but the Dynavin doesn't automatically switch to camera view. I have to manually select the camera at which point everything works as expected. I want it to select the camera automatically when I'm in reverse.

Strangely, I don't have an option for "Reverse" in settings. It literally doesn't exist on my screen.

Any help is much appreciated.
There is a setting in the menu in the Dynavin to have the camera automatically come on with 12V signal. With that off, the camera wont show on the display until you go to camera. So if you turn that setting on, when it gets the 12V+ signal from your reverse light, it will switch the display to camera, and it will quite down the music.

You have it wired just like I do. All that you are missing is that menu setting.

Page 15 of this manual (16 in pdf page numbers), you need to set this to "CAM" or else it will not jump to camera when the 12V+ signal is on:
User-manual-N7-Pro.pdf (dynavin.de)
 

·
Registered
Joined
·
53 Posts
There is a setting in the menu in the Dynavin to have the camera automatically come on with 12V signal. With that off, the camera wont show on the display until you go to camera. So if you turn that setting on, when it gets the 12V+ signal from your reverse light, it will switch the display to camera, and it will quite down the music.

You have it wired just like I do. All that you are missing is that menu setting.

Page 15 of this manual (16 in pdf page numbers), you need to set this to "CAM" or else it will not jump to camera when the 12V+ signal is on:
User-manual-N7-Pro.pdf (dynavin.de)
Appreciate the fast reply. Here’s the thing: I don’t have that setting:
Satellite radio Radio Vehicle audio Audio equipment Technology
Radio Satellite radio Plant Automotive design Vehicle audio
Radio Satellite radio Vehicle audio Personal luxury car Auto part


Sorry for the factory screen protector.

Based on what I’ve read the “Reverse” option should be rightbelow “Time Zone.”
 

·
Super Moderator
'03 325iT Mystic Blau
Joined
·
6,666 Posts

·
Registered
2003 325i MT
Joined
·
357 Posts
I just tried that and only have the choice finder PDC for “L-R” and “R-L”.

I double checked and I am running the latest firmware.
Try changing the Square button to something other than "Camera" (for example CarPlay) then see if you have the "Reverse" option. I think it may assume you are using the camera as a forward facing camera when you put the shortcut button as camera.
 

·
Registered
Joined
·
53 Posts
Try changing the Square button to something other than "Camera" (for example CarPlay) then see if you have the "Reverse" option. I think it may assume you are using the camera as a forward facing camera when you put the shortcut button as camera.
I just gave that a shot to no avail.

I did speak with Dynavin (and wow, what customer service!). I have everything configured as it should be at the camera end. The red power wire off the RCA cable is connected to the correct input on the Dynavin.

There is no longer a "Reverse" option in the System menu, but rather an "Aftermarket Camera" checkbox, which I have checked.

I suspect that I may have connected the yellow RCA cable from the camera to the yellow RCA input on the Dynavin. It looks like the yellow RCA cable from the camera should be connected to the BROWN RCA input on the radio. When I have a chance to take it apart I'll update this thread.

Many thanks for all your help!
 

·
Registered
2003 325i MT
Joined
·
357 Posts
I just gave that a shot to no avail.

I did speak with Dynavin (and wow, what customer service!). I have everything configured as it should be at the camera end. The red power wire off the RCA cable is connected to the correct input on the Dynavin.

There is no longer a "Reverse" option in the System menu, but rather an "Aftermarket Camera" checkbox, which I have checked.

I suspect that I may have connected the yellow RCA cable from the camera to the yellow RCA input on the Dynavin. It looks like the yellow RCA cable from the camera should be connected to the BROWN RCA input on the radio. When I have a chance to take it apart I'll update this thread.

Many thanks for all your help!
Dynavin USA is great. The lady and the Jeff are awesome. He worked with me off hours while I was in the car with wires exposed.
 

·
Registered
Joined
·
53 Posts
I took the whole thing apart and the yellow RCA cable is definitely connected to the correct, brown plug.

The red wires on the video cable are connected, right? I can connect the “REVERSE TRIGGER” to the red wire either behind the radio or in the trunk, right?
 

·
Registered
Facelift 330ci 6MT
Joined
·
1,581 Posts
901 - 920 of 920 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top