BMW E46 Fanatics Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hey guys! Just got my 05' 325ci.... two days ago while driving my DCS, eBrake and TPMS lit up. Checked tire pressure, checked brake fluid and did try to reset both DCS and TPMS buttons.... lights still on. Need help in figuring out what caused this. Appreciate your inputs. Thanks!
 

Attachments

·
Registered
Joined
·
802 Posts
fu.cken love your user name !!:thumbsup:
 

·
Registered
2006 325Ci M56 5MT
Joined
·
1,031 Posts
wow that looks just like mine when i got it, i hope you have an M54 and not a M56 engine, sorry off topic
 

·
Registered
Joined
·
607 Posts
same car & same exact thing happened to me. mine was Steering Angle sensor but yours might be some other parts. get a fanatic or indy shop check your codes. if it is steering angle sensor then you are screwed because its a :censor: to get to. part is ~$300, Reset And code the sensor ~$150, Labor $400
:banghead: i got a used one and 3 months later i still haven't found the right shop to get t done at. :ben:
 

·
Registered
Joined
·
1,759 Posts
For TPMS: if you checked/Filled the air, then the light should go of by itself after driving it few miles. Maybe spare tire is missing air?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
so you have not fixed the problem. is it ok to drive the car with those warning lights on?

same car & same exact thing happened to me. mine was Steering Angle sensor but yours might be some other parts. get a fanatic or indy shop check your codes. if it is steering angle sensor then you are screwed because its a :censor: to get to. part is ~$300, Reset And code the sensor ~$150, Labor $400
:banghead: i got a used one and 3 months later i still haven't found the right shop to get t done at. :ben:
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
checked all 4 tire pressure, everything ok and drove it for 25miles...still on. have not checked spare though, does that also have a sensor?

For TPMS: if you checked/Filled the air, then the light should go of by itself after driving it few miles. Maybe spare tire is missing air?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #11
all 4 tires are new when i got it a month ago, light came out 4 days ago. just checked tire pressure earlier and everything seems to be ok. you think i should still have my alignment checked?

car is off alignment due to incorrect tire pressures.

you may also need new tires since uneven wear will set off the dsc lamp.
 

·
Registered
Joined
·
607 Posts
so you have not fixed the problem. is it ok to drive the car with those warning lights on?
yea its fine as long as you don't want the DSC feature which most of cars on the street don't have anyways.. but it get annoying seeing those lights...

checked all 4 tire pressure, everything ok and drove it for 25miles...still on. have not checked spare though, does that also have a sensor?
Done the same myself too. that does not fix the problem

all 4 tires are new when i got it a month ago, light came out 4 days ago. just checked tire pressure earlier and everything seems to be ok. you think i should still have my alignment checked?
i actually think this might fix our problem if you have a steering angle code although lots of mechanic told me alignment doesn't have to do anything with DSC. I'm planing on getting an alignment and having the dealer to reset / re-calibrate my sensor to see what happens. yesterday my airbag light also came on :bang head: i hope that doesn't have to do with anything.
 

·
Registered
Joined
·
152 Posts
I have the same problem. It was determined by the BMW stealership that it is the sensor. I will have a DIY on the subject by the end of the weekend, because the lights are driving me :censor: crazy, and nobody has had the guts to try this on there own and post a DIY @ the same time.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #14
Thanks for all the inputs! Just came from an indy shop, they read the code and it was the Steering Angle Sensor. They were able to reset it but light went back on as I was on my way home. They quoted $500 for the sensor and labor....
 
1 - 14 of 14 Posts
Top