BMW E46 Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2003 325i automatic, stock.

When driving yesterday in heavy rain and commuter traffic, my DSC, ABS and brake lights all came on and my car jumped a little, felt like I was rear-ended (I wasn't) and slowed (downshifted). I pulled over, turned off the car. Tried to restart it, engine cranked but didn't start. Tried again, no crank, nothing. Hazard lights worked, radio worked. Battery only 1 yr old. Got it jumped, red battery light came on then went off. So not the alternator.

Shop says it needs a new DME. After reading posts here it seems like it might just be a sensor issue, faulty wheel speed sensors. My car is covered by an extended warranty which the shop says will cover the DME replacement. I'm thinking this is overkill and the shop may be trying to make money off the warranty.

If it's no money out my pocket, should I be concerned about replacing the DME? What issues can result (or should I look for) from replacing the DME? If it is the speed sensors, would a new DME detect this? I was completely surprised when I was told the DME needed replaced, not expecting that. Any advice is appreciated.
 

·
Just Nuts
Joined
·
7,253 Posts
Sounds like the battery to me, even if it is only 1 year old. It's also possible the rain water short circuit something.
 

·
Registered
Joined
·
5,018 Posts
I make alot more money off other parts DME's are dealer only and have little to no profit. Trust me I don't replace a DME for fun or profit!!!! Anyways the DME is covered by BMW for 10 year 100k
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Well the tow truck driver checked this out already and said it wasn't the battery, he suggested alternator. The shop already ruled out both of these possibilities, which is why I thought it might be a speed sensor. thanks for your input.
 
1 - 5 of 5 Posts
Top