E46 Fanatics Forum banner
261 - 280 of 316 Posts

· Registered
Joined
·
1 Posts
Hey, thanks for the guide. I got my LCM updated and flashed to get rid of the tamper dot. However I've got rear light warning lights on the dash. I suspect it's lost the LED taillights and thinks it's running bulbs.
I've tried adding +LEDH and flashing a blank MAN file but still got the warning lights. Any suggestions? TIA
 

· Super Moderator
'03 325iT Mystic Blau
Joined
·
6,882 Posts
Hey, thanks for the guide. I got my LCM updated and flashed to get rid of the tamper dot. However I've got rear light warning lights on the dash. I suspect it's lost the LED taillights and thinks it's running bulbs.
I've tried adding +LEDH and flashing a blank MAN file but still got the warning lights. Any suggestions? TIA
If your car didn't come with LED tails flashing a blank .man will delete them.
 

· Registered
Joined
·
3 Posts
@TerraPhantm Hi! Let me bother you with a quick question. (I see you are the real expert here, so i mention you :D)
I've read your explanation of the stickers on the lcm but i want to make sure.
I have a EU 2001 coupe, with non adaptive xenon, and i want to make sure that i buy an LCM with the right configuration. The LCM i'm about to buy says "ECE SA dyn LL m FLC", "LEAR", "HW:25 SW:3.6" on it's sticker.
Am i right that the "LL" part is not a problem for me since i have a pre facelift car?
Thank you in advance.
 

· Registered
Joined
·
83 Posts
Has anyone else had issues with NCS Dummy and the 4.7 LCM?

Export FSW_PSW with NCS Expert, fire up NCS Dummy, select LSZ.C37 and get errors. Tried all the other LSZ.Cxx and also get errors.

perhaps my daten files are older than the 4.7? Or do I need to tell NCS Dummy that this is an E85 LSZ?

05/01 build date, so I have ZCS car.

LCM works with no errors after installation. Booted up NCS Expert, read the ZCS, read the LCM, did a FGNR_SCHRIEBEN job (No FA_SCHRIEBEN on early cars), Key off, Key on, no tamper dot but light errors on check control. Ok, now go to NCSexpert folder, open up FSW_PSW.MAN, make sure its empty, save, go into NCS Expert under LCM and do a SG_CODIEREN. Key off, Key on, good to go.

Now I want to use NCS_Dummy to code triple blink or whatever, got stuck doing it manually because I can't get NCS Dummy trace mode to work.
 

· Registered
Joined
·
83 Posts
Has anyone else had issues with NCS Dummy and the 4.7 LCM?

Export FSW_PSW with NCS Expert, fire up NCS Dummy, select LSZ.C37 and get errors. Tried all the other LSZ.Cxx and also get errors.

perhaps my daten files are older than the 4.7? Or do I need to tell NCS Dummy that this is an E85 LSZ?

05/01 build date, so I have ZCS car.

LCM works with no errors after installation. Booted up NCS Expert, read the ZCS, read the LCM, did a FGNR_SCHRIEBEN job (No FA_SCHRIEBEN on early cars), Key off, Key on, no tamper dot but light errors on check control. Ok, now go to NCSexpert folder, open up FSW_PSW.MAN, make sure its empty, save, go into NCS Expert under LCM and do a SG_CODIEREN. Key off, Key on, good to go.

Now I want to use NCS_Dummy to code triple blink or whatever, got stuck doing it manually because I can't get NCS Dummy trace mode to work.

I fixed it by not being Dumb.

You need to run codierdaten_liesen and not codierindex_liesen
 

· Registered
Joined
·
2 Posts
Good morning!
I did the flash on a E85 Z4 LCM and it works fine! Thank you for that very good and useful tutorial!

I have one question, its a bit specific to the E85 and it's bi-xenon headlights. I fitted the xenon headlights from the LCI model in the pre LCI car. The difference is the missing H7 halogen bulb in these headlights. When I use the headlight flasher while the low beam is off, I can hear the xenon shutter work but the xenon does not ignite. With low beam on, everything is working as it should.

Does anybody know how to fix this behaviour? I think it's a coding issue.

Another thing, if somebody knows in which forum I can get help, please give me an advice.
 

· Registered
Joined
·
2 Posts
Good morning!
I did the flash on a E85 Z4 LCM and it works fine! Thank you for that very good and useful tutorial!

I have one question, its a bit specific to the E85 and it's bi-xenon headlights. I fitted the xenon headlights from the LCI model in the pre LCI car. The difference is the missing H7 halogen bulb in these headlights. When I use the headlight flasher while the low beam is off, I can hear the xenon shutter work but the xenon does not ignite. With low beam on, everything is working as it should.

Does anybody know how to fix this behaviour? I think it's a coding issue.

Another thing, if somebody knows in which forum I can get help, please give me an advice.
Thank you! It's:

LH_MIT_BIX
aktiv

After I changed this it works as it should!
 

· Registered
Joined
·
1 Posts
Hi all!
Thanks for the tutorial, working properly.
I have lost of the types and compatibility of LCM-s.
Somebody told me, the halogen LCM is not working fully functionally with xenon lights.
I this true? And the second thing.
There are two different LCM. They are sw 4.7 flashed from 3.6.
If i want to put an non-automatic headlight module to a car, what have this function before i only need to replace the front of the LCM?
And it will works? Or its have compatibility issue?
I doesnt try it yet.
Thanks!
Vehicle Grey Automotive design Personal luxury car Font

Digital camera Reflex camera Point-and-shoot camera Camera Camera lens
 

· Registered
BMW 320i
Joined
·
7 Posts
Hi guys,
I flashed everything like shown and it worked fine.
I put everything in the car and do the NCS Expert Job.

Now I have one problem:
The right taillight is not working, if they are switched on. If I use the Coming Home feature, they are working.

Did someone had the same problem? I used a second LCM. Should the serial number match?

Original: BMW 6 936 826 (ECE SA dyn LH m FLC)
Flashed: BMW 6 936 825 (ECE SA dyn LL m FLC)
 

· Registered
BMW 320i
Joined
·
7 Posts
Hello. After flashing SW3.6 LCM to SW4.7 i have issue with rear right lamp. I have e46 320d 2003yera sedan (wagon) - Europe. Is this bin file from US LCM?

coding this sw4.7 lcm with empty MAN file and entering correct FA with NCS does nothing.

What else can i do to turn on rear right light? Also i have DRL module for angel eyes and with this SW4.7 they are still on even if the xenon is turned on.
Hello haxigi, did you fix it?
I have now the same problem

This was in 2018 from the looks of my backups.

Should be one of:

PIN37_49_PARKL or PIN29_30_PARK

Looks I made PIN29_30_PARK nicht_aktiv and PIN37_49_PARKL aktiv.
PWM_WERT2_ALS_BL_AUSGANG went from wert_02 to wert_01

To be honest, I can't remember why I changed these, but I tested a bunch of different settings until I could make it work. Its possible that if you know on which pin that specific bulb is connected to, it should be fairly easy to figure out which setting to change in NCS.

Other option is to test a few, but I remember this was a manual fix for me.
I tried this but didn't Change anything.
 

· Registered
Joined
·
5 Posts
Just to make sure, before I buy anything useless - LH version of LCM is for facelift sedans, which also have lights on the boot lid, unlike the touring, where the lights on boot lid are just fog and reverse lights. Most of what I could find are LL units, probably from other tourings, so I should be fine fitting one into my touring, right?

The problem with right rear light not working concerns only sedans (if a LL unit was used), if I understand correctly.
 

· Super Moderator
'03 325iT Mystic Blau
Joined
·
6,882 Posts
Just to make sure, before I buy anything useless - LH version of LCM is for facelift sedans, which also have lights on the boot lid, unlike the touring, where the lights on boot lid are just fog and reverse lights. Most of what I could find are LL units, probably from other tourings, so I should be fine fitting one into my touring, right?

The problem with right rear light not working concerns only sedans (if a LL unit was used), if I understand correctly.
I don't understand any of what you're saying.
LCMs can be used in any coupe/vert/sedan/touring/compact, it's in how they're coded that determines what pins are lit under what circumstances. IIRC the one that I currently have in my touring had originally been in facelift sedan, but I've had ones out of coupes in it in the past. I've been through a few before finding one with sw version 4.0 and the circuitry to drive the xenon leveling motors.
 

· Registered
BMW 320i
Joined
·
7 Posts
I don't understand any of what you're saying.
LCMs can be used in any coupe/vert/sedan/touring/compact, it's in how they're coded that determines what pins are lit under what circumstances. IIRC the one that I currently have in my touring had originally been in facelift sedan, but I've had ones out of coupes in it in the past. I've been through a few before finding one with sw version 4.0 and the circuitry to drive the xenon leveling motors.
That's true for you, but you can't put a touring LCM in a Sedan. The right rearlight will not work. I try to code it in various pin settings.
It will not work.
 
261 - 280 of 316 Posts
Top