BMW E46 Fanatics Forum banner

1161 - 1180 of 2022 Posts

·
Registered
Joined
·
541 Posts
Discussion Starter #1,161
Hi Pete, is there a way to access the a camera through the Reverse Camera Pins of the PIBUS ? I would like to make an app that would start the camera without having to put the gearbox in reverse. If this is possible, can you please show me how? or give me a hint where to start ?

Regards
If you haven't got bluetooth, you can use the Phone button to do that already.
Otherwise, the source code is at: https://github.com/PeteAU/pibus
 

·
Registered
Joined
·
226 Posts
The "Pwr Out" header on the pibus could almost supply 2A @ 5V. The regulator is rated at 3A, diodes at 3A and inductor at 2.5A. But it would get a little bit hot and the caps are probably a bit small.



There's room on the board to add some parts to control anything in software through GPIO26 on the Pi.
Then you could connect a relay between "SG" and 5V/12V and control it from the Pi.
Pete , I've got a ardrino relay which is logic triggered . Is it just case of bridging gpio 26 to sg on the PCB ?

OR would I still need a 100k resistor and a fet to trigger ?

Relay http://www.dx.com/p/arduino-5v-relay-module-blue-black-121354#.V4ClWZUkpLM
 

·
Registered
Joined
·
541 Posts
Discussion Starter #1,163
Pete , I've got a ardrino relay which is logic triggered . Is it just case of bridging gpio 26 to sg on the PCB ?

OR would I still need a 100k resistor and a fet to trigger ?

Relay http://www.dx.com/p/arduino-5v-relay-module-blue-black-121354#.V4ClWZUkpLM
Normally it can't drive a relay directly without a FET, but there appears to be one on your relay board (Q1). Can't see a schematic on that page, but maybe it's OK to connect direct.

Otherwise, a 2n7002 costs nearly nothing on ebay.
 

·
Registered
Joined
·
17 Posts
Hi All,

Just wanted to quickly introduce myself and provide my gratitude to Peter for all the wonderful, hard work he continues to provide on the PiBUS. Also, thank you to all the members here that have provided help, feedback and ideas to nurture this great project.:bow:

After receiving my RPi3 (from Element14) & PiBUS very quickly after about 2 days, installation was surprisingly easy and uneventful thanks to the great information you guys have provided. Mind you, reading/scanning through 59 pages of this thread was hard going but well worth it. Peter's automated PiBUS install script after installing OpenELEC 6.0.3 made it so easy for a newbie like me to get up and running stress free!:clap:

I had a small glitch a day after the install that you guys might be able to shed some light on. All seemed to work fine after the initial install but when I came back to the car the next morning after booting up, some functions on the head unit would not function. I couldn't get the MODE button to switch to the RPi/PiBUS and the Radio would not function. However, TV, OBC and Telephone would work fine. After checking fuses, I tried rebooting, cold booting and completely unplugging RPi/PiBUS but still no Radio. It wasn't until I plugged the CDC back in that I was able to get the Radio to function again. I then proceeded to unplug CDC and re-plug RPi/PiBUS. Now everything is back working again for the moment, hopefully will stay that way?

Anyone else experience this issue and has it re-occurred?

Any case and mounting recommendations, I've now got plenty of space where the CDC used to be?

My setup details:
2006 BMW X5 E53 3.0d
Widescreen display with TV, Radio & Bluetooth Telephone. No Nav.
Raspberry Pi 3, PiBUS v4, OpenELEC 6.0.3

Thanks all.
 

·
Registered
Joined
·
541 Posts
Discussion Starter #1,166
I had a small glitch a day after the install that you guys might be able to shed some light on. All seemed to work fine after the initial install but when I came back to the car the next morning after booting up, some functions on the head unit would not function. I couldn't get the MODE button to switch to the RPi/PiBUS and the Radio would not function. However, TV, OBC and Telephone would work fine. After checking fuses, I tried rebooting, cold booting and completely unplugging RPi/PiBUS but still no Radio. It wasn't until I plugged the CDC back in that I was able to get the Radio to function again. I then proceeded to unplug CDC and re-plug RPi/PiBUS. Now everything is back working again for the moment, hopefully will stay that way?

Anyone else experience this issue and has it re-occurred?
I haven't heard of that behaviour before. You mean AM/FM didn't work until you reconnected the CD stacker? Sounds a bit weird. If it happens again, I would suggest removing "-m" from the autostart.sh file.
 

·
Registered
Joined
·
17 Posts
That's correct. No AM/FM until CD stacker was plugged back in. Will try the -m flag if it does happen again. Thanks Peter.

Sent from my SM-G900I using Tapatalk
 

·
Registered
Joined
·
6 Posts
Just have to say what an amazing job PeteAU has done with developing the E46/E53 platform.
I have been looking for years at Entertainment upgrade option, Android head units and alike and have never seen this until last night.
And even better, it came from an Aussie!!!!

I had always wondered how i could integrate a Android OTT box into the X5 (M8 or M8S or similar) but Pete's work around takes it even further.
He has also addressed the mpeg4 issue with TV Tuner... Brilliant!

After reading most of this thread, i see a lot of people are using a barebones install of Kodi
More for playing local media.

Has anyone loaded addons or activated IPTV Simple Client and imported their own list of IPTV channels?
I already run an 8" tablet in the X5 for this reason, with an unlimited 4-20mb/s 3G connection.
Very handy for keeping up to date with live MotoGP of F1 streams on the go.

When doing this Mod, does it still allow "AUX" input for 3.5mm socket in-dash for Music playback?
(I don't like the Bluetooth option, because of battery drain (phone) and music compression)

Thanks

Vehicle Details:
2006 BMW X5 E53 3.0d
Widescreen display with TV, Nav, CD (MP3 type), Tape, Radio, Reverse Cam & Bluetooth Telephone
 

·
Registered
Joined
·
17 Posts
Hey Salty Dog,
Haven't played with addons yet but hoping to have a go at skins and implement BigToms OBC in Kodi.
AUX should not be lost when using a "standard" PiBUS install since we're replacing it with the CD Changer and emulating. I love the sound quality coming from the PiBUS and won't bother using AUX again. I think the X3 E83 guys do some black magic with AUX but that shouldn't apply to you for an E53?

Sent from my SM-G900I using Tapatalk
 

·
Registered
Joined
·
99 Posts
Thanks X_V, i must admit, the Sound Quality from the X5 is very disappointing for the vehicle of its class.
The Becker BM54 has a lot to answer for.
The BM54 upgrade is probably the best money you'll spend, the stock speakers are terrible (unless you've got the HK system), but pushing more power through them does make them sound a heck of a lot better.

I can confirm I've still got an AUX input when I scroll with the Mode button on my 16:9 screen, I've got nothing plugged into it, but it's definitely there.
 

·
Registered
Joined
·
6 Posts
Thanks harmzs
Yes, we have the BM54 upgraded output stage fitted.
And its still a dismal sound system by any measure.

Hence why i found it interesting when people were blown away by the sound from the RPi/PiBUS combo...
Enough though you get a better DAC, its still being pumped through the BM54 and OEM speakers.
I'm just wondering why its all of a sudden so much better?

I appreciate you can play FLAC and a high sampling rate, but is it really that much better?
The dynamic range etc?
 

·
Registered
Joined
·
79 Posts
Thanks harmzs
Yes, we have the BM54 upgraded output stage fitted.
And its still a dismal sound system by any measure.

Hence why i found it interesting when people were blown away by the sound from the RPi/PiBUS combo...
Enough though you get a better DAC, its still being pumped through the BM54 and OEM speakers.
I'm just wondering why its all of a sudden so much better?

I appreciate you can play FLAC and a high sampling rate, but is it really that much better?
The dynamic range etc?
I wonder if depends on the age of your vehicle. I have a stock BM54 and stock speakers, and yes it's way better. My audiofile mate spends thousands of pounds on all his audio systems and he can tell there is a distinct change in audio quality in my car.

I suppose if the speakers have had a hard life then they could be worn out. The ones in my 51 plate look nearly new and have had a very easy life. I don't think the stock amps inside the 54 are that bad either, there's a heck of a lot worse supplied with other makes of car. The major problem with the 54 is heat dissipation in the amp section, which is the main reason why they stop working.

Whether you have stock amps or upgraded amps makes very little difference if the speakers are rubbish, worn out, bad wiring, poorly fitted... etc. etc. There's so many variables.

I hope you can find a root cause to your bad sound.
 

·
Registered
Joined
·
226 Posts
The factory system has a few weak links but some bits are ok to quite good.. The factory mid range speakers for example a quite good .

The op amps in the bm53/54 tuners could also be found in some studio mixing desks in the late 90s and the dsp was up there in its day. I looked into changing the opamps out but found the sound quality to be very good if you did the RCA mod which bypassed the final output stage. I did the mod and tried it via an AMC amp and Sennhesier headphones and the results where very good.

What lets the sound quality down on the bm53/54 is its final balanced output stage. I've fitted a dsp, aftermarket speakers and amps. Switching the dap input between preamp mod and balanced outputs is quite obvious. The drop in sound quality on balanced was quite noticeable.

The other main issue with the system is the lack of air space on e46 coupes and sedans for the front speakers .(compacts are fine ! )
I think there would be roughly a couple of litres of airspace which ultimately limits the mid bass outputs .

Petes audio output stage looks great. Compare this to the output stage of the factory stacker even with the limitations of the bm53/54 you should hear an improvement .

I'll be running a second DAC on my Pi when finished which will send the audio straight into my DSP and aftermarket system.
 

·
Registered
Joined
·
6 Posts
I wonder if depends on the age of your vehicle. I have a stock BM54 and stock speakers, and yes it's way better. My audiofile mate spends thousands of pounds on all his audio systems and he can tell there is a distinct change in audio quality in my car.

I suppose if the speakers have had a hard life then they could be worn out. The ones in my 51 plate look nearly new and have had a very easy life. I don't think the stock amps inside the 54 are that bad either, there's a heck of a lot worse supplied with other makes of car. The major problem with the 54 is heat dissipation in the amp section, which is the main reason why they stop working.

Whether you have stock amps or upgraded amps makes very little difference if the speakers are rubbish, worn out, bad wiring, poorly fitted... etc. etc. There's so many variables.

I hope you can find a root cause to your bad sound.
BMX X5 2006 (E53) non DSP
OEM Speakers
OEM BM54 with Modded Amp section (not sure what exact kit)
Vehicle well looked after, older owners.

All wiring is fine. Its just a very average sound IMO.
(had a good car stereo before, so i know what to expect)

Anyway, its getting a bit off topic i guess :)
 

·
Registered
Joined
·
17 Posts
RiPi/PiBUS Enclosure

Hi Folks,

Here's my 1st attempt at an enclosure. I didn't like the idea of having it "floating" around so bolted it down using one of the brackets off the old CD Changer in a cheap plastic Jiffy box from Altronics.

However, still working on the sticker - that's just a bit of Photoshop fun:shhh:
Looking for some thumbscrews for the lid and making the status LED's more visible. Or better still, getting the PiBUS to use the LED's on the Boardmonitor, now that would be cool! :thumbsup:
 

Attachments

·
Registered
Joined
·
1 Posts
Audio Noise E38

Hello everyone.

just want to say a big thank you to all u people out there for such a great project, this is my first post btw, have got all the gear ready for install but of late been so busy with work, kids, wife ect. the owners of e38s should have a look at this thread for audio problems, apparently bmw did a odd wiring hack back in the day which will cause audio noise when installing new equipment such as grom/dice products which i will have to overcome this problem as well.
Hope this helps, good luck, cheers.

http://www.bimmerboard.com/forums/posts/99394/_nr_
 

·
Registered
Joined
·
541 Posts
Discussion Starter #1,180 (Edited)
GPS track logging

Hi,

I made a little tool you can use to visualize your GPS track recorded in your ibus.txt file. Here's how to run it on the Pi:

Code:
wget http://pibus.info/sw/ibus_to_gpx
chmod +x ibus_to_gpx
./ibus_to_gpx < ibus.txt > ibus.gpx
Then copy the ibus.gpx file to your PC and stick it in a web site like: http://www.gpsvisualizer.com/map_input

Kind of cool to see where you've been driving, but a bit like big brother is watching! What else can we do with this?
 

Attachments

1161 - 1180 of 2022 Posts
Top