E46 Fanatics Forum banner
1 - 20 of 89 Posts

· Registered
Joined
·
185 Posts
Discussion Starter · #1 ·
I finally reached the mileage where I needed to do this. I took a lot of pictures since it seems like people are always doing this one and are always having questions. Anyways, I hope it helps some of you all out. Let me know if anythings wrong with the writeup, it's quite long so there's lots of room for errors.

There are directions to replace all of the following:
Water Pump
Upper Radiator Hose
Lower Radiator Hose
Expansion Tank and Cap
Temperature Sensor
Thermostat
Coolant

http://www.bmw330ci.net/maintenance/completecoolant.php

Enjoy! - Paul
 

· Registered
Joined
·
464 Posts
Just did this 2 months ago, it's a must for cars over 150,000...espically the constant failing water pump :)
 

· Registered
Joined
·
257 Posts
That's cool, i gotta do this soon.

One thing to note, the sensor connector can be released by pushing the wire clip in. I discovered this recently. LOL. I used to move it out and some time it pops off and i loose them too.

 

· Registered
Joined
·
975 Posts
Very good write. Just did all of that to my father in laws 2001 325xi this past weekend. Had to replace the thermostat under the expansion tank as well. And found that its a must to replace the temperature sensor with the lower hose, if not it will leak like hell.
 

· Registered
Joined
·
29 Posts
I just bought the coolant container im gonna do it tomorrow, but i guess I will buy everything else at 150,000 kms im at 141,000 right now but the container cracked cause some one installed it WRONG (@BMW) and a pulley ate away on it...
 

· Registered
Joined
·
268 Posts
Will do this once the weather warms up abit :)

Thanks!!

Also, for Automatics...is the process much different or more difficult?
If so can you explain in greater detail.

I can't seem to find any articles on cooling system overhaul for just autos.
 

· Registered
Joined
·
185 Posts
Discussion Starter · #10 ·
My knowledge on automatics is pretty slim this I do know:

You will need a fan clutch tool. Unlike the manuals, that have an electric fan automatics have a mechanical fan. This means you need a special tool and the process is different to remove it. I also have heard that the 32mm nut on there is reverse threaded so be careful.

Maybe someone who has done an automatic can share a little bit better. Besides the mechanical fan I believe the rest of the process is almost exactly the same.
 

· Registered
Joined
·
268 Posts
a big thank you for the DIY cooling system overhaul writeup! here are a few notes from my experience this morning.

1. lower radiator hose removal ... a huge pain in the a$$! there is little to no room for leverage ... just keep pulling and eventually, after about 10 minutes for me, it will finally break free from the radiator.
2. expansion tank removal ... another big pain in the a$$! follow the recommendation in this DIY by using a socket with an extension and then pound the crap out of it from the bottom up. again, takes time but it will break free. keep your mouth closed while you're doing this unless you want a little coolant as a refreshing drink.
 

· Registered
Joined
·
1,190 Posts
For the fan you will need tools that hold the pulley and righty loosy the nut with thin 36mm. Just one blow clockwise and it will loosen up. The lower radiator. It took me 4 hours until I figured it out. I cut the hose then cut the outer plastic end part of the hose but be careful not to go all the way and messed up the radiator ****. I did 3 vertical indentation to the plastic and then just pry it with your screw driver. It was so easy. If you cannot pull the expansion tank, place your jack underneath the exp tank and have some wood (i used my rubber mallet) for extension and jack and jack it for few inches and release the jack, wella you loosen up the exp tank and just pull it.
 

· Registered
Joined
·
623 Posts
I, for one, would like to say that even if you have a high mileage car, if things don't need replacing, I don't think they need to be replaced. Sure, things like the water pump which have a bad reputation and are hard to inspect might be a very good idea--I upgraded to a Stewart pump myself based on just that concern. But hoses, for example, you should be able to manually inspect for wear and age. If they're fine, there really isn't any point in replacing them. When the thermostat goes bad, you'll know about it, just stay on top of inspecting your car and reading codes regularly and I think you can save a lot of money by not replacing perfectly good parts. Just my two cents!

That said, good writeup, thanks! :) I'm a big fan of your site.
 

· Registered
Joined
·
182 Posts
^^ I agree, I replaced the thermostat, water pump and expansion tank and cap this past weekend, hoses were in perfect shape, I double checked the orings inside and all fine so I reused them .. I am all up for replacing hard to reach parts while doing something else, like on this case I was doing the thermostat so why not the water pump? but hoses? you can access those without removing anything else on the car
 

· Registered
Joined
·
406 Posts
After 4 and half hours I finally just finished replacing my expansion tank, water pump, thermostat and hoses as well as lower hose temp sensor and fluid level sensor under the exp tank. Now the low coolant indicator light is on the dash. I put back the old fluid level sensor and the dash light is still on, coolant level is full. I bled the system for air, the heat is working fine in the car. Has anybody have any ideas what is wrong? Thanks.
 

· Registered
Joined
·
623 Posts
^^ I agree, I replaced the thermostat, water pump and expansion tank and cap this past weekend, hoses were in perfect shape, I double checked the orings inside and all fine so I reused them .. I am all up for replacing hard to reach parts while doing something else, like on this case I was doing the thermostat so why not the water pump? but hoses? you can access those without removing anything else on the car
Good point. If it's impossible to reach without taking everything apart and you're already in there, might as well if you're not sure.
 

· Registered
Joined
·
182 Posts
After 4 and half hours I finally just finished replacing my expansion tank, water pump, thermostat and hoses as well as lower hose temp sensor and fluid level sensor under the exp tank. Now the low coolant indicator light is on the dash. I put back the old fluid level sensor and the dash light is still on, coolant level is full. I bled the system for air, the heat is working fine in the car. Has anybody have any ideas what is wrong? Thanks.
check the level the next day to top it off if needed

I had a low coolant light the day after, let it sit overnight on a level surface, top it off and light went off

other than that I don't know what to tell you, maybe try resetting the code if you have a scanner and see if it comes back
 
1 - 20 of 89 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top