E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Ride of the Month Challenge!
1 - 12 of 12 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Problem: Climate Control Display off and buttons non-functional. No blower, no controls...nothing.


What I've Done to try and fix:

Researched the HVAC system used in the e46

Used the search function and advanced search function here

spent hours reading various forum posts dealing with similar issues

Checked all fuses in glove box 3 times.

Replaced blower relay and a/c relay (new)

Replaced Climate Control Unit with a friends working model

Replaced Blower motor (pain in the ass)(new)

Replaced FSR (new)(long shot but figured it may go out in the future anyway)

Additional info:

The buttons illuminate when my headlights are on just fine but the screen stays blank and the buttons don't function.


Next idea:

Test for continuity and power in the wiring. If anyone can give me info about which connectors and which wires to test I would really appreciate it.


Any Input?
 

·
Registered
Joined
·
1 Posts
Hey, I now have this exact problem of no power, no blower, no controls on my climate control... Any ideas? Did you find a solution?
 

·
Registered
Joined
·
5 Posts
I am having the same problem too!

I read online from someone who was having the same issue that it may have something to do with the external climate control sensor. Mines along with this poster keeps reading -40. I looked under the bottom of the front end and saw a wire with a harness hanging. I didn't know what it belonged to, so I tied around another part to keep from getting damaged. I then discovered that it wasn't reading the outside temp anymore. Then one day, my heat control panel just quit. No power, just illuminates when the headlights are on. Does anyone have experience with this issue. My hubby and I are pulling our hair out and scratching our heads. No heat, in Detroit, 1 degrees above 0. :facepalm:
 

·
Registered
Joined
·
0 Posts
Hey, I now have this exact problem of no power, no blower, no controls on my climate control... Any ideas? Did you find a solution?
+1
Same situation. Buttons don't work, screen doesn't light up. Buttons DO light up when parking and headlights are on. I just swapped HVAC unit with a friends (which works) and same problem. Now I can rule out the unit being faulty. Don't know how to proceed...fuses? Fsr?


Sent from BimmerApp mobile app
 

·
Registered
Joined
·
0 Posts
+1
Same situation. Buttons don't work, screen doesn't light up. Buttons DO light up when parking and headlights are on. I just swapped HVAC unit with a friends (which works) and same problem. Now I can rule out the unit being faulty. Don't know how to proceed...fuses? Fsr?


Sent from BimmerApp mobile app
 

·
Registered
Joined
·
0 Posts
I just replaced the FSR and checked fuses. Still nothing. Auto part


Sent from BimmerApp mobile app
 

·
Registered
Joined
·
238 Posts
my e46 does not do this, but I had a 91 model silverado back in the day that used to dot his. I would have to pull on the hvac control and clean the connections where it plugs in. I used aerosol electric parts cleaner done the trick every time.
 

·
Registered
Joined
·
489 Posts
Have any of you scanned for error codes? Perhaps that might help you track the cause of the problem up the chain. It could maybe be a battery voltage or a General Module issue. I've also had fuses that look fine, but when replaced with a fresh fuse, were in fact shot. I bet the button illumination is powered by a separate voltage source from the LKM just as it is in older BMWs, so those buttons would light up regardless of your HVAC's condition.
 

·
Registered
Joined
·
0 Posts
That's a good idea. Fuses are relatively cheap, might as well... Thanks


Sent from BimmerApp mobile app
 
1 - 12 of 12 Posts
Top