BMW E46 Fanatics Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
159 Posts
Discussion Starter #1
Got about a week to pass emission test in Ga. About a month ago did a code reset to clear the CEL from a cylinder misfire and 300miles later I’ve go no codes but two monitors haven’t completed. Evap and secondary air. Cold start at least 20 times,all sorts of driving-highway speed, etc. Seems the cycle should be complete? What the heck?


Sent from my iPad using Tapatalk
 

·
Registered
E30M3 Race F10 535 R1150Rt M Coupe
Joined
·
1,533 Posts
Evap can be problematic, however secondary air should have been run on every morning start, if not more. Something's up.

Does the secondary air pump run?
 

·
Registered
E30M3 Race F10 535 R1150Rt M Coupe
Joined
·
1,533 Posts
Do you have a garage that is cooler than outside?
After running the car, by placing it in the garage (if cooler than outside) overnight should set the Evap.
 

·
Registered
Joined
·
159 Posts
Discussion Starter #5
Balidawg there are no codes. It failed emissions due to the monitor cycle not completing. Apparently there are 8 monitors, 6 completed and passed. 2 are incomplete-Evap and secondary air. I don’t think either will fail or throw a code but I don’t understand after driving it for several hundred miles at all speed ranges it doesn’t finish the monitor cycles.

I am using a basic OBD2 handheld, not BMW specific. Don’t have a Fusion.


Sent from my iPad using Tapatalk
 

·
Here to serve y’all
2004 330Ci 85k miles
Joined
·
11,617 Posts
Evap and secondary air. I don’t think either will fail or throw a code.
Both the EVAP system and SAP system are regularaly tested by the DME and will throw codes if not working right.
Put aside the handheld scanner and get set up with OBD Fusion. It runs circles around most scanners and is less than $30 for adapter and app. Hit the link below and read post #1. There’s a PDF file link in there for how to run a diagnostic report, choose the right PIDs, set up the logging, record the right kinds of logs for review on here, etc. We’ve helped hundreds solve their engine and emissions issues using that tool and reviewing the data.

Once its set up, do a diagnostic report at hot idle, upload it to dropbox, share a link to it in here. That will provide the data I requested earlier (and more) and give us a starting point for seeing what’s up with your car. The next thing is a cold start log with all the important PIDs.

My guess is your pre-cat O2 sensors are old/lazy and preventing SAP system from completing its test successfully. But need to see some real data to be sure.
 

·
Registered
Joined
·
159 Posts
Discussion Starter #8
# miles on the car?
190k or so. Evap finally cleared,only secondary air missing now. Hopeful, found out the outside temp sensor was fouled and it was showing -40 on the cluster. Fixed it up, now normal. Thinking it may effect the sec air. I’ve had a dozen of these things, never had one take so long to clear......


Sent from my iPad using Tapatalk
 

·
Premium Member
2003 330cic, 2003 325iT
Joined
·
4,115 Posts
Damning the emissions system for your car not passing is like blaming gravity for the pain in your knee.

I would take a minute and see if there are maintenance opportunities masking themselves as emissions issues. At one level, you can pass with one uncleared test. But I would take a look at the schedule in my footer - at 190k, you should have replaced the pre-cat sensors, MAF, fuel pump, fuel filter (2x), and all the intake rubber by now.
 

·
Registered
E30M3 Race F10 535 R1150Rt M Coupe
Joined
·
1,533 Posts
How is your thermostat? On newer cars, if the thermostat isn't 100%, some of the monitors will not run.
 
1 - 10 of 10 Posts
Top