BMW E46 Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter #1
I have an 02 330ci and its 3 year old this 11/1. I have 17K and drive only on weekend. Last couple of days when I first turn on the car. The coolant light comes one and I turn off the car and back on the light is gone. It is normal for the coolant ligh to come on with only 17K. I haven't check the coolant, but if I have to fill it up. Can I just put in any coolant or have to buy specific brand for our car?

TIA
 

·
Registered
Joined
·
156 Posts
I have a 1999 that was doing the same thing. All I did was add a couple cups of water. You can get coolant from BMW or go to a parts store and get whatever they recommend. Seems kind of strange that you would be low on coolant with that many miles on your car. :dunno: Check it. If you see a little white or gray plastic rod sticking up out of the radiator you're low. Just top it off. :thumbup: It also could be a leak or a bad sensor. :thumbdwn:

ABE
 

·
Registered
Joined
·
1,052 Posts
My 02 330i is at 15k miles, 2 1/2 year of owning it. The coolant on mines came on around 10k. It's no big deal, it's common on these cars to burn a little oil or coolant. You can either add distill water or add coolant. If you can't get the BMW coolant, I recommend Prestone, the one in the yellow bottle. Been using it for years and even my old man has been using it for like decades and never had problems with it. Plus, it can be mix to any make or color coolant according to the instructions on the label.
 

·
Registered
Joined
·
218 Posts
Use only phosephae free

here are some brands:
Shell Fully Formulated Phosphate Free Coolant/Antifreeze
Prestone® Extended Life 5/150 Antifreeze/Coolant is phosphate, silicate, and borate free.
SynLube™ Synthetic Coolant/Anti-Freeze.
Texaco Heavy Duty Coolant Phosphate-Free

or spend $18 from BMW
 

·
Banned
Joined
·
2,046 Posts
Just added coolant on Sunday, Haloween. I thought it was odd too to have to add coolant so early, but I searched and it seems kinda normal. There were no signs of leaks in my car either and I only added about 2 little styrofoam cups of liquid before the little red stick popped up to the max recommended level. I only have 11,000 miles but it wasn't that much fluid. If it happens again soon, I'll take the car in to the dealer to have them check it out for an internal leak or something.
 
1 - 7 of 7 Posts
Top