BMW E46 Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1 (Edited)
Hey guys. So six months ago I purchased my first bmw, a 2002 e46 325ci with 110k miles. It came with a lot of issues that I've been sorting out, but I cannot solve this misfire.

Basically, if you go over 3500rpm in any gear and hold the rpm constant for 5 to 10 seconds, it misfires and CEL pops up. So say ur going 4k rpm and hold it: misfire. If the rpm varies, its fine no issue. So u can go through every gear until redline no problem, as long as rpm is varied. As soon as its over 3500rpm and u hold it: misfire. So say you forgot to go into 5th gear going a constant 70mph, itll misfire. Turning engine on/off makes it go away.

Heres where it gets more complex. Its not one specific cylinder. Sometimes its cylinder 6 misfire with fuel cutoff, sometimes its 4, or 2 or 5 etc. Its always different when it misfires so i dont think its injectors or coils or plugs.

Chasing other codes Ive changed the following: crank sensor, exhaust cam sensor, checked the disa and replaced the seal, new maf, oem 4 pronged ngk spark plugs, new bosch ignition coils all around, lower intake boot, most/all vacuum leaks, fuel filter, air filter, fuel system cleaners

Ive been chasing other codes simultaneously. First was lean codes (turned out to he intske boot and that vacuum plug at the back of the intake mani) then crank sensor, then maf, then exhaust cam sensor. Everytime i fix it something else pops up lol. And now the new codes ive been getting since last two weeks were for o2 sensors (bank 2 sensor 1 and 2, p1085 and p0158). No lean codes so doubt its a vacuum leak? But could be. When its really cold i get a cylinder 1 misfire on idle so maybe the ccv nèeds to be changes or fixed. Also i know i need a new valve cover gasket.

Any ideas on what can cause this specific misfire? I dont think ccv, o2s, or vc gasket or possible vaccuum leak will cause this but i could be wrong. My friend says camshaft or internal engine damage but i dont know. I just dont want to dump more money chasing this problem if its a big problem. Thank you so much for any advice!
 

·
Premium Member
Joined
·
28,970 Posts
What OBDII tool do you have?

Have you confirmed 100% that the O2 sensors are connected properly to the correct engine bay connection/the proper Bank?? You need to think long and hard how you answer this question and if you answer the question Yes, you need to explain what you to did to confirm the wiring.

What is the history on the fuel pump and filter?

Have you checked the engine to body ground wire under the vehicle near the passenger/right side motor mount? The frame side connection is the problem side.
 

·
Registered
Joined
·
11,072 Posts
Does the car have the original fuel pump?? Engines don't typically have issues at revs over 3500 rpm unless a coil is going bad OR the fuel supply is inadequate.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #4 (Edited)
What OBDII tool do you have?

Have you confirmed 100% that the O2 sensors are connected properly to the correct engine bay connection/the proper Bank?? You need to think long and hard how you answer this question and if you answer the question Yes, you need to explain what you to did to confirm the wiring.

What is the history on the fuel pump and filter?

Have you checked the engine to body ground wire under the vehicle near the passenger/right side motor mount? The frame side connection is the problem side.
i have an innova 3100c.

I have not confirmed that th o2's are connected properly BUT my logic is telling me they are physically wired properly. the reason i say this is because i had the typical o2/lean codes 6 months ago and following your thread i sealed up two vacuum leaks and there were no o2 codes until now. so i feel like they would be wired correctly(?).

fuel filter i changed, pump no clue to be honest.

i have not checked the ground i will do that today, thank you.

Does the car have the original fuel pump?? Engines don't typically have issues at revs over 3500 rpm unless a coil is going bad OR the fuel supply is inadequate.
unconfirmed, but i would assume original pump. wouldnt fuel pump cause issues when i redline the car. i row through the gears redlining it quite often and have no issues. only when i hold it constant at an rpm over 3500(?) it decides to misfire. no idle issues either 98% of the time.
 

·
Premium Member
Joined
·
28,970 Posts
i have an innova 3100c.

I have not confirmed that th o2's are connected properly BUT my logic is telling me they are physically wired properly. the reason i say this is because i had the typical o2/lean codes 6 months ago and following your thread i sealed up two vacuum leaks and there were no o2 codes until now. so i feel like they would be wired correctly(?).

fuel filter i changed, pump no clue to be honest.

i have not checked the ground i will do that today, thank you.


unconfirmed, but i would assume original pump. wouldnt fuel pump cause issues when i redline the car. i row through the gears redlining it quite often and have no issues. only when i hold it constant at an rpm over 3500(?) it decides to misfire. no idle issues either 98% of the time.
Park the Innova tool. For Logging you cannot beat OBDFusion, less than $30 and you are up and running.

You cannot use Logic with these cars or any car in general. Easy enough to trace the wiring of 1 Pre-cat O2 sensor, mark the sensor wiring at the connector Bank #1 or Bank #2. Unplug the sensor that is marked and see what sensor quits responding on the scan tool that ends up settling at 0.475 Volts. If the Bank # agrees, great, if not swap sensors and VERIFY.

Fuel pump problems do not always show up under full throttle, after 3000 RPM under heavy load the DME switches over to a Speed/Density mode, the O2 sensors and feedback fuel control is too slow and not needed. The Fuel Management is on the Rich side to protect the engine, so therefore a Lean condition at part throttle will likely be masked.

Again, do not attempt to think about things Logically on modern vehicles.
 
1 - 5 of 5 Posts
Top