E46 Fanatics Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi has anyone experienced this code I keep getting then. The service engine light turns off and on and when I check for code I always get the same ones I know is part of a vacuum leak or running to lean but why do they keep coming on and off could it be a faulty sensor ??
 

·
Registered
Joined
·
1,326 Posts
Easiest/quickest way to find vacuum leaks is by smoke testing .That resolves most all P0174's. Search forum for "how to's". If not, post with details i.e. work done, brand of each parts used, and who/where work was done.
 

·
Registered
Joined
·
2,313 Posts
Everything is new and I still get the codes
What is "everything" ("everything" suggests a new car as in EVERYTHING was replaced)? Have you done ANY investigation to the actual engine like a.... I dunno - a smoke test as most of the videos on lean codes WILL include. You have not, in any way, suggested what you have done to diagnose or to fix the problems. The50skid on You Tube has many a video on lean codes and smoke testing. There are more than 20 things that can cause lean codes - have you checked ALL of them out (replacing parts is not checking)??

Any codes can come and go - all depends on what is causing the leaks. I spent a year trying to hunt down a lean code, fixed it, then had it popup again 6 months later and spend another 2 months figuring it out till it was fixed.

Pretty much ANYONE who has a 20+ year old BMW has had a vacuum leak at some point.
 
1 - 8 of 8 Posts
Top