E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I've tried searching the forums came across a few things that have SIMILAR problems but nothing the same....I have a 325ci 5spd. If I put my car into reverse and break nothing happens but right after driving backwards and breaking then putting it in 1st and going forward and break my car makes a click sound sometimes just once and other times almost like something had a very minor grind...I'm completely dumbfounded on this problem and would love some suggestions.

sorry if this has been brought up before I just wanted to know if other people had the same problem that if you reverse and break nothing happens but after that going forward and break it makes the sound then.........I don't want to dull out money for a mechanic to inspect when I got e46fanatics' inspectors...hahaha :)

Many thanks!
 

·
Registered
Joined
·
2,291 Posts
I would check the brake pads asap because it sounds like they're near the end of their lives. Next thing you will see is a cutting pattern in your rotors. Has the brake warning light on the dashboard lit up?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
I would check the brake pads asap because it sounds like they're near the end of their lives. Next thing you will see is a cutting pattern in your rotors. Has the brake warning light on the dashboard lit up?
Nope I'll check after this storm blows through this week. It's raining every 30 minutes.
 
1 - 4 of 4 Posts
Top