E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 2 of 2 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 ·
Managed to get CarSoft to talk to the DME without too much trouble, but couldn’t get a response from any other system (car is a manual). Found a couple of postings suggesting this is a known problem and the ‘cure’ is to use the engine bay diagnostic connecter. Well I don’t have one of those on my 2001 330CI.

Wiring diagram suggests that DME/EGS serial line (K1) is on pin 7 of the OBDII connector whereas the other systems are on pin 8 (K2). Watching the interface LEDS it looks like CarSoft is only driving the K1 line, so I tried swapping the pin 7 and pin 8 wires over. Sure enough this lost the DME connection but the rest appeared.

Currently I have disconnected the wire from pin 8 and bridged pins 7 & 8 on the CarSoft OBDII connector (didn’t want to mess with the car wiring). This works and I can see all the systems that my car has.

Early days but I’m not sure how useful some of the codes are. I’ve found a pretty detailed description of the DME ones but the names of the others aren’t that useful. I seem to have a permanent ‘EGS connection disturbed’ from the instrument cluster, but is this significant as I have a manual transmission? How do I know which ones matter and which ones don’t?
 

·
Registered
Joined
·
20 Posts
John949, you are a legend. Read your post and turns out I was having the same problem, changed the obd2 plug wiring and now I can see almost all the modules.
 
1 - 2 of 2 Posts
Top