E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
1,300 Posts
Discussion Starter · #1 · (Edited)
Need some help...
switched my water pump, thermostat and belts today - and I just finished, went to start the car and boom nothing...

When I turn the key, the xenons start flashing like mad as well as the cluster, and nothing else, and it makes a clicking noise....

Anyone else have this happen? Right now I am SOL.... :dunno:

I think there could be a short somewhere from draining my coolant? ar maybe the battery is flat and there is not enough charge to turn the starter?
 

·
A Flammable Plumber
Joined
·
4,016 Posts
most likely is ur battery .. check all ur connections , if that doesnt work just go to autozone and have them recharge it




yes if u hear a clicking thats ur starter solenoid working but there is not enough current to work the starter
 

·
Registered
Joined
·
91 Posts
fusable link

if you didn't unhook the battery before doing the work you may have shorted the system out and burned out the fusable link. I haven't done this on my BMW but I did it once on a Mitsubishi Gallant and it did the same thing. I called the dealer and talked to service tech and he told me about the fusable link and where to find it. I then went to Advance Auto Parts and spent about $3 on the part and went home, plugged it in and everything was OK.
 

·
Registered
Joined
·
190 Posts
check the bettery ^0^
 

·
Registered
Joined
·
1,300 Posts
Discussion Starter · #5 ·
Riped it all apart, checked all the connections....

And it was the battery... :thumbup:

If the car was not so bust flippin the xenons, i bet it would have had enough to muster up some energy to start...oh well..

Thanks for all the help anyway...
 
1 - 5 of 5 Posts
Top