E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
377 Posts
Discussion Starter · #1 ·
These are the symptoms:

- Car blows 'luke warm' air only despite temp maxed out to 32/C and engine heated up :thumbdwn:
- No change even with A/C ON or OFF :thumbdwn:
- Cold A/C is working fine :thumbup:
- Temp gauge is working fine :thumbup:

Anyone have any idea what's gone wrong? :dunno:

Winter is coming and I am fabsolutely freezing! HELP!!!
 

·
Registered
Joined
·
155 Posts
sup

does it start out warm and get progressively colder?, that could be the ikha climate control fan is dead, otherwise may be a bad heater contol valve.


Stock323iSaloon said:
These are the symptoms:

- Car blows 'luke warm' air only despite temp maxed out to 32/C and engine heated up :thumbdwn:
- No change even with A/C ON or OFF :thumbdwn:
- Cold A/C is working fine :thumbup:
- Temp gauge is working fine :thumbup:

Anyone have any idea what's gone wrong? :dunno:

Winter is coming and I am fabsolutely freezing! HELP!!!
 

·
Registered
Joined
·
112 Posts
I just recently had to get the 'final stage resistor' replaced from the dealer cause the blower fan wasn't working. Same symptoms - little to no heat...
 

·
Registered
Joined
·
377 Posts
Discussion Starter · #4 ·
mikemartin9 said:
does it start out warm and get progressively colder?, that could be the ikha climate control fan is dead, otherwise may be a bad heater contol valve.
The strange thing is that when the engine is cold, the air is cold as normal. It then gets progressively warm but it then stops there and never gets hot. Icy in London right now...
 

·
Registered
Joined
·
377 Posts
Discussion Starter · #5 ·
E46erfan said:
I just recently had to get the 'final stage resistor' replaced from the dealer cause the blower fan wasn't working. Same symptoms - little to no heat...
Was it expensive, and did you fit it yourself?
 

·
Registered
Joined
·
112 Posts
I believe it was a $70 part, install 3/4 hour. Don't know total cost because car was under warranty. This should give you an idea though.
 
1 - 7 of 7 Posts
Top