E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 10 of 10 Posts

·
Registered
Joined
·
10,690 Posts
Discussion Starter · #1 · (Edited)
So, a few months ago I jumped on a group-by to get a new version of the D110 enclosed sub by BSW. I finally got the sub shipped to me two weeks ago. This past weekend, I installed the sub.

I have a Sedan, w/ an aftermarket head unit, and no fold down seats.

Equipment: 7/10
The actual sub box/enclosure is great. Solid construction, and fairly light weight, although I wish it was a little thinner. Not a deal-breaker

What bothered me about the equipment is two fold:
1). The RCA input connectors are on the wrong side of the box/enclosure. They are placed on the left outer wall which is right next to the left wheel arch. There is barely enough room for Jesus than two RCA cables and the power connector. This should have been thought out more. I think a better spot would have been on the back side of the unit next (facing the rear seat).
2.) The equipment cable is too short on one end (negative lead) and too long on the other (power). The negative lead cannot reach the bolt that ties the negative battery terminal cable to the frame. There are other places to ground than behind stock amplifier. I was forced to remove the lining on order to get at this specific bolt.

Install: 2/10
The instructions need improvement. The instructions on the website are outdated. They are from the original D110. I am pretty good at following instructions and I got lost. Pictures only tell part of the story. More written detail needs to be added to the whole process. For example:
1.) Better pictures!!
2.) How to lay the sound deading material to the box, including measurements.
3.) How the bolts should be assembled prior to dropping them into the whole for hanging.
4.) The location to put the front arms of the sub are completely incorrect. I had rubber grommets (sp) covering the wholes.
5.) The pictures are wrong when it comes to identifying the holes to place the quick release bolts to the trunk.

Performance: 9/10
So far, I am impressed. I am still in break-in period (after one day). I though cannot wait to get past it.

Feel free to ask more questions....
 

·
Registered
Joined
·
1,131 Posts
thanks for review. i have yet to install mine.

once you fiddle with the settings, be sure to post a pic of them :)
 

·
Registered
Joined
·
10,690 Posts
Discussion Starter · #4 · (Edited)
All,

I tried taking some pictures tonight of the sub settings and my camera would not focus (crappy lens). The red and white knobs are set to half. Boost is set to 0 and the crossover is set to just past 90.

Besides the sub settings, I also have my after market head unit set to the following:
Bass: +4 out of +10
Sub Out: +8 out of +15

The combination of the two works for me. I will try again with my phone's camera tomorrow.
 

·
Registered
Joined
·
1,131 Posts
All,

I tried taking some pictures tonight of the sub settings and my camera would not focus (crappy lens). The red and white knobs are set to half. Boost is set to 0 and is set to just past 90.

Besides the sub settings, I also have my after market head unit set to the following:
Bass: +4 out of +10
Sub Out: +8 out of +15

The combination of the of the two works for me. I will try again with my phone's camera tomorrow.
just to clarify, boost set to 0 or 90?

thanks for posting this info. i will have to fiddle with my factory hu bass settings to see what would work best for me, but your reply is helpful. i have yet to install the sub box yet b/c it is at the upholstery shop still along with a bunch of other things.

thanks again. i am looking forward to pics when you get them.
:thumbsup:
 

·
Registered
Joined
·
10,690 Posts
Discussion Starter · #7 ·
just to clarify, boost set to 0 or 90?

thanks for posting this info. i will have to fiddle with my factory hu bass settings to see what would work best for me, but your reply is helpful. i have yet to install the sub box yet b/c it is at the upholstery shop still along with a bunch of other things.

thanks again. i am looking forward to pics when you get them.
:thumbsup:
Boost is zero, crossover is set to just past 90. I may change the crossover to be below 90. Not sure yet.
 

·
Registered
Joined
·
1,256 Posts
Jeff - Thank you for your review! We really appreciate it. We are working through ALL installation guides right now and many are being coverted to video installation guides as that seems to work best for most customers. For instance just this morning I added a 3 part Stage 1 installation guide for the Sedan(E46). First video for that install we have offered.

Working through them all now but with so many different fitments. Working on it now!
 

·
Registered
Joined
·
10,690 Posts
Discussion Starter · #10 ·
Jeff - Thank you for your review! We really appreciate it. We are working through ALL installation guides right now and many are being coverted to video installation guides as that seems to work best for most customers. For instance just this morning I added a 3 part Stage 1 installation guide for the Sedan(E46). First video for that install we have offered.

Working through them all now but with so many different fitments. Working on it now!
Halston,

I would still publish a paper document version of the install. Wifi/computers are not always available.
 
1 - 10 of 10 Posts
Top